hdu1124 数论 N阶乘有多少个尾0

Factorial

Time Limit : 2000/1000ms (Java/Other)Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 57Accepted Submission(s) : 32
Problem Description
The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.
ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

Input
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output
For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input
 
 
6 3 60 100 1024 23456 8735373

Sample Output
 
 
0 14 24 253 5861 2183837

Source
Central Europe 2000

题意:N阶乘有多少个尾0(1 <= N <= 1000000000)

/*容易知道5以后的阶乘都是偶数 那么产生新的0 只有当偶数*5 那么对于25 可以分为 5*5

那么 25的阶乘等于24的阶乘*5*5 会多出2个0

125的阶乘等于124的阶乘*125 会多出3个0

所以只要看n里有多少个5的倍数多少个25的倍数。。。。。。

(由于*25的产生的2个0 可以在计算5的倍数时去掉一个 25对应相当于1个0 同理125 也相当于一个0 )

那么结果为n/5+n/25+n/125+......*/

#include<stdio.h>
int main()
{
	int n,ans,i,k,cnt,num;
	while(scanf("%d",&k)!=EOF)
	{
		while(k--)
		{
			scanf("%d",&n);
			ans=0;
			num=1;
			while(num<=n)
			{
			     num*=5;
				 ans+=n/num;
			}
		printf("%d\n",ans);
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值