Mixing Milk(贪心)

Mixing Milk

Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

PROGRAM NAME: milk

INPUT FORMAT

Line 1:Two integers, N and M. 
The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers wants per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from. 
Lines 2 through M+1:The next M lines each contain two integers, Pi and Ai
Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges.
Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

 

SAMPLE INPUT (file milk.in)

100 5
5 20
9 40
3 10
8 80
6 30

OUTPUT FORMAT

A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

SAMPLE OUTPUT (file milk.out)

630 

   题意:

   要装满M(范围是0到5000)那么大的牛奶,提供N(范围是0到2000000)个店铺。每个店铺最大供应奶量为Ai(范围是0到2000000),其中每一升需要花Pi(范围是0到1000)的钱,购买的量可以等于或者小于最大供应量,输出满足需求量M的最小花费金额。

 

   思路:

   使金额最小,那么则从单价最小的开始购买,在为满足需求量时,应购买该店铺的最大供应量。如果购买该店铺的最大供应量超过了需求量的时候,则按需求量和该店铺的最大供应量的差值来购买,这时候达到的金额就为最小值了。

 

   AC:

 

#include<cstdio>
#include<algorithm>
using namespace std;

struct seller
{
	int per;
	int max;
};
seller people[5005];

int cmp(seller a,seller b)
{
	return a.per<b.per;
}

int main()
{
	int N,M,i,sum=0,price=0,left;
	scanf("%d%d",&N,&M);
	for(i=0;i<M;i++)
	  scanf("%d%d",&people[i].per,&people[i].max);
	sort(people,people+M,cmp);
	
//	printf("\n");
//	for(i=0;i<M;i++)
//		printf("%d %d\n",people[i].per,people[i].max);
//保险起见,还是输出来看看有没有正确存储
   
    for(i=0;i<M;i++)
    {
    	if(sum<N)
    	{
//这时候的已购买量加上这个店铺的最大供应还是小于需求量的话
//就购买该店铺全部的牛奶(该店铺的最大供应量)	
            if(sum+people[i].max<=N)
    	    {
    	    	sum+=people[i].max;
    	    	price+=people[i].per*people[i].max;
    	    }
//如果加上后超过需求量了,则按差值购买
    		else if(sum+people[i].max>N)
    		{
//这里必须用left来保存剩余量
//如果直接在sum进行赋值操作的话
//sum+=(N-sum);prince+=(people[i].per*(N-sum));
//后面乘以的sum已经改变了,已经变成了N,而不是两者的差值了
//写之前还是要动下脑子再写……    			
                        left=N-sum;
			sum=N;
    			price+=(people[i].per*left);
    		}
    	}
//买够了就跳出循环,输出最小金额		
                if(sum==N) break;
    }
    printf("%d\n",price);
}

   总结:

 

   第一次没有Bug没有想错然后一遍AC的,虽然题目简单,但是还是有点小激动。一开始还是犯了个低级错误,所以写每句代码前都要考虑清楚才行,检验下到底是错还是对……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值