Mayor's posters(线段树 + 离散化 + 区间更新)

Mayor's posters
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 40494  Accepted: 11780

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

 

      题意:

      给出 T,代表有 T 组数据。每组数据给出 n(1 ~ 10000)块板,每块板都有一个左右边界 (1 ~ 10 ^ 7),新放进去的板会覆盖掉原来的板,求出最后能看见的板能有多少种。

 

      思路:

      线段树。区间更新。维护线段的覆盖颜色,这里有个问题就是这里的覆盖的编号指的是线段的编号,而不是点的编号,比如样例

      3

      1 10

      1 4

      5 10    答案是2

      3

      1 10

      1 4

      6 10   答案是3

      这样的话,离散化之后就会带来问题,离散化后同样都是 1 2 3 4,得出来的答案永远都是2,故答案错误。

      所以当把左右边界放到一个数组之后,比如 1  4 6 10,将相邻两个数相差 1 的添加多一个中间值,处理后就是1,2,4,5,6,10,之后再做离散化求覆盖情况即可。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 10005;

int cl[MAX], cr[MAX];
int num[MAX * 100], ans;

int color[MAX * 100];
int col_temp[MAX], sum;

void push_down(int node, int l, int r) {
        if (color[node]) {
                int mid = (r + l) >> 1;
                color[node << 1] = color[node];
                color[node << 1 | 1] = color[node];
                color[node] = 0;
        }
}

void build (int node, int l, int r) {
        if (r == l) {
                color[node] = 0;
        } else {
                int mid = (r + l) >> 1;
                build (node << 1, l, mid);
                build (node << 1 | 1, mid + 1, r);
                color[node] = 0;
        }
}

void update(int node, int l, int r, int al, int ar, int col) {
        if (ar < l || al > r) return;
        if (al <= l && ar >= r) {
                color[node] = col;
                return;
        }
        if (r == l) return;

        push_down(node, l, r);
        int mid = (r + l) >> 1;
        update(node << 1, l, mid, al, ar, col);
        update(node << 1 | 1, mid + 1, r, al, ar, col);
}

void query(int node, int l, int r) {
        if (color[node]) {
                if (!col_temp[ color[node] ]) {
                        ++sum;
                        col_temp[ color[node] ] = 1;
                }
                return;
        }
        if (r == l) return;

        int mid = (l + r) >> 1;
        query(node << 1, l, mid);
        query(node << 1 | 1, mid + 1, r);
}

int main() {
        int t;
        scanf("%d", &t);

        while (t--) {
                int n;
                scanf("%d", &n);

                ans = 0;
                for (int i = 0; i < n; ++i) {
                        scanf("%d%d", &cl[i], &cr[i]);
                        num[ans++] = cl[i];
                        num[ans++] = cr[i];
                }

                sort(num, num + ans);

                int a = ans;
                for (int i = 1; i < ans; ++i) {
                        if (num[i] - num[i - 1] > 1) {
                                num[a++] = num[i - 1] + 1;
                        }
                }
                ans = a;

                sort(num, num + ans);
                ans = unique(num, num + ans) - num;

                build(1, 1, ans);
                for (int i = 0; i < n; ++i) {
                        int l = lower_bound(num, num + ans, cl[i]) - num;
                        int r = lower_bound(num, num + ans, cr[i]) - num;
                        update(1, 1, ans, l + 1, r + 1, i + 1);
                }

                memset(col_temp, 0, sizeof(col_temp));
                sum = 0;
                query(1, 1, ans);

                printf("%d\n", sum);
        }

        return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值