joj 2484

2484: Chinese Character Art


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s65536K1322473Standard

Chinese characters is a wonderful graphic. Many foreigners write Chinese characters on his T-shirt. You can draw a special Chinese characters '田' (tian) on different size now.

Input

Each line of input is a positive interger N (N<=40). The input file is terminated by N=0.

Output

For each input, you should draw graphic using character '+' with given size N. The width of your drawing is 2*N+1, and the height is 2*N+1. Just see the sample to understand the deail. Output one blank line after each symbol.

Sample Input

2
0

Sample Output

+++++
+ + +
+++++
+ + +
+++++
 
 
 
 
 
 
 
 
 
 
 

 

/*
	 关键是水题
	 row % n == 0时候,这一行全部输出为 +
	 如 row % n != 0 那么这一行的
		col % n == 0时候输出为 +
		否则输出为 “ ”
*/
#include <stdio.h>
int n =0;
int main()
{
	while(scanf("%d",&n),n)
	{
		for(int i=0;i<(2*n+1);i++)
		{
			for(int j=0;j<(2*n+1);j++)
			{
				if(i % n == 0)
				{
					printf("+");
					continue;
				}
				if(j % n == 0)
					printf("+");
				else
					 printf(" ");
			}
			printf("\n");
		}
		printf("\n");
	}	
	return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值