joj 1149Binary Number 二进制移位操作

1149: Binary Numbers


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K1690653Standard

Given a positive integer n, nd the positions of all 1's in its binary representation. The position of the least significant bit is 0.

 

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

 

 

Task

Write a program which for each data set:

 

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

 

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

 

 

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

 

Sample Input

1
13

Sample Output

0 2 3

/*
  水题
  最基本的移位操作
*/
#include <stdio.h>

int d = 0,n;
int main()
{
	scanf("%d",&d);
	for(int i=0;i<d;i++)
	{
		scanf("%d",&n);
		if(n == 0)
		{
			printf("0\n");
			continue;
		}
		int j = 0;
		while(n != 0)
		{
			if(n & 1 == 1 && n != 1) //表示末位是否为1
			{
				printf("%d ",j);
			}
			if(n == 1)
				printf("%d",j);
			n = n >>1; //移位
			j++;
		}
		printf("\n");
	}
	return 0;
}
 

 

水题一个,但是关键是最后一个j输出的时候只能是输出数字,不能多输出一个空格,否则会PE错误。

所以n == 1 的时候要特殊处理

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值