题目描述
Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。
输入输出格式
输入格式:
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
第一行:物品个数N和背包大小M
第二行至第N+1行:第i个物品的重量C[i]和价值W[i]
输出格式:
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
输出一行最大价值。
输入输出样例
输入样例#1: 复制
4 6 1 4 2 6 3 12 2 7
输出样例#1: 复制
23
这道题很显然,需要用01背包问题解决,下面提供四种解法(仅第四种AC),由易到难
1.记忆化递归,容易理解但浪费空间
#include <bits/stdc++.h>
using namespace std;
int n;
int w[3405], v[12882];
//n+1个之后的物品可用,背包剩余容量为W+1
int dp[3405][12882] = {0};
int dfs(int s, int W)
{
if(dp[s][W] >= 1)
return dp[s][W];
if(s >= n)
dp[s][W] = 0;
else if(w[s] > W)
dp[s][W] = dfs(s+1, W);
else
dp[s][W] = max(dfs(s+1, W), dfs(s+1, W-w[s]) + v[s]);
return dp[s][W];
}
int main()
{
int W;
scanf("%d%d", &n, &W);
for(int i = 0; i < n; i++)
scanf("%d%d", &w[i], &v[i]);
printf("%d\n", dfs(0, W));
return 0;
}
2.递推式,但是仍然是二维数组。
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n, W;
scanf("%d%d", &n, &W);
int w[n+1], v[W+1];
//n+1个之后的物品可用,背包剩余容量为W+1
int dp[n+1][W+1] = {0};
for(int i = 0; i < n; i++)
scanf("%d%d", &w[i], &v[i]);
for(int i = n-1; i >= 0; i--)
for(int j = 0; j <= W; j++)
if(j < w[i])
dp[i][j] = dp[i+1][j];
else
dp[i][j] = max(dp[i+1][j], dp[i+1][j-w[i]] + v[i]);
printf("%d\n", dp[0][W]);
return 0;
}
3.递推式,但是仍然是二维数组。
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n, W;
scanf("%d%d", &n, &W);
int w[n+2], v[W+2];
//前n+1个物品,总重量小于等于W+1的最大价值
int dp[n+1][W+1] = {0};
for(int i = 1; i <= n; i++)
scanf("%d%d", &w[i], &v[i]);
for(int i = 1; i <= n; i++)
for(int j = W; j >= w[i]; j--)
if(j < w[i])
dp[i][j] = dp[i-1][j];
else
dp[i][j] = max(dp[i-1][j], dp[i-1][j-w[i]] + v[i]);
printf("%d", dp[n][W]);
return 0;
}
4.递推式,一维数组,省时省空间。
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n, W;
scanf("%d%d", &n, &W);
int w[n+2], v[W+2];
//重量为W+1时可获得的最大价值
int dp[W+1] = {0};
for(int i = 1; i <= n; i++)
scanf("%d%d", &w[i], &v[i]);
for(int i = 1; i <= n; i++)
for(int j = W; j >= w[i]; j--)
if(dp[j] < dp[j-w[i]]+v[i])
dp[j] = dp[j-w[i]] + v[i];
printf("%d", dp[W]);
return 0;
}