POJ3714 Raid

Description

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union’s attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
Sample Output

1.414
0.000


#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const double inf=1e50; 
int n,t; 
struct node{
    double x,y;
    bool flag;
}a[200050],tmp[200050];
bool cmpx(const node &a,const node &b)//不加const有错误 
{
    return a.x<b.x;
}
bool cmpy(const node &a,const node &b)
{
    return a.y<b.y;
}
double dis(node p,node q)
{
    if(p.flag==q.flag) return inf;//;
    return sqrt((p.x-q.x)*(p.x-q.x)+(p.y-q.y)*(p.y-q.y));
}
double work(int l,int r)
{
    if(l==r) return inf;//
    int mid=(l+r)/2,cnt=0;
    double ans=min(work(l,mid),work(mid+1,r));//左边求一个,右边求一个,选择最小的 
    for(int i=l;i<=r;i++)
        if(fabs(a[i].x-a[mid].x)<=ans)  
            tmp[++cnt]=a[i];//凡是与m的距离小于ans的点都记录下来
    sort(tmp+1,tmp+cnt+1,cmpy);
    for(int i=1;i<=cnt;i++)
        for(int j=i+1;j<=cnt;j++)//保证不重复 
        {
            if(fabs(tmp[j].y-tmp[i].y)>ans) break;
            ans=min(ans,dis(tmp[i],tmp[j]));
        }
    return ans;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&a[i].x,&a[i].y);
            a[i].flag=0;        
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&a[i+n].x,&a[i+n].y);
            a[i+n].flag=1;
        }
        sort(a+1,a+2*n+1,cmpx);
        printf("%.3f\n",work(1,2*n));
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值