P1118 [USACO06FEB]数字三角形Backward Digit Su…

题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4
  4   3   6
    7   9
     16

Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9 16 最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]
输入输出格式
输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例
输入样例#1:

4 16

输出样例#1:

3 1 2 4

说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。

实际上在刚开始做这道题的时候就感觉到每个数用了好几次,那到底用了几次呢?在纸上找找规律就发现是一个杨辉三角的次数。
+可行性剪枝,ac.

#include <iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
int n,sm,t,f[15][15],b[15],c[15],a[15];
void print()
{
    for(int i=1;i<=n;i++)
       cout<<c[i]<<" ";
   cout<<endl;
   exit(0);
}
void dfs(int t,int s){
    if(t>n) return ;
    if(s>sm) return ;
    if(s==sm && t<n) return ;
    for(int i=1;i<=n;i++)
    {
        if(!b[i])
        {
            b[i]=1;
            c[t]=i;
            s+=i*f[n][t];//4个数,就是第四行
            //cout<<c[1]<<" "<<c[2]<<" "<<c[3]<<" "<<c[4]<<" "<<s<<endl;
            if(s==sm  && t==n) {print();}
            else 
               dfs(t+1,s);
            b[i]=0;
            s-=i*f[n][t];
        }
    }
}
int main()
{
    scanf("%d%d",&n,&sm);
    for(int i=1;i<=n;i++){
        f[i][1]=1;  
        for(int j=2;j<=i;j++)
            f[i][j]=f[i-1][j]+f[i-1][j-1];
    }
   // for(int i=1;i<=n;i++){
        //for(int j=1;j<=i;j++)
           // cout<<f[i][j]<<" ";
           // cout<<endl;
  //  }
    dfs(1,0);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值