Microsoft ScriptControl 控件使用指南

Microsoft ScriptControl 控件使用指南

一,前言

很多知识用到时总是不太把握,往往都得要上网找资料查一番。
将一些实用的资料收藏在这里,作备忘之用。本贴随时会更新。


部分资料来源于网络,感谢分享者,如有雷同,绝无恶意,皆为学习。


随着动态网页的出现,脚本语言已经被越来越多的人认识、接受并撑握。在程序中加入对脚本的支持一方面可以最大限度的扩展程序的应用范围,另一方面也方便程序员利用现有脚本提供的一些特别的功能(如正则表达式等)。

很显然要自己去实现一个脚本解释器是不现实的。好在已经有了可以复用的组件,那就是Microsoft ScriptControl 。这是一个ActiveX控件,随Windows2000一起发布,如果要在2000以前的Windows中使用则需要安装该控件(可以到MS的网上找到)。

ScriptControl接口


属性名称

类型

备注

AllowUI

BOOL

检测是否允许运行用户的接口元素。如果为False,则诸如消息框之类的界面元素不可见。

CodeObject

Object

脚本暴露给宿主调用的对象。只读。

Modules

Modules

宿主提供给脚本的组件库模块。只读。(COM组件通常都是以对象收集的形式向用户提供可以留给用户二次开发的对象集合,每一个收集即一个Modules

Language

String

设置或获取脚本引擎解释的语言,例如:VBScriptJScript

Name

String

脚本引擎的名称。只读。

Procedures

Procedures

返回模块中定义的过程的集合

SitehWnd

HWND

在脚本中显示UI的父窗口句柄

State

Enum

设置或返回控件的状态,如果为0,控件只执行语句但不转发事件,为 1则为加入的本控件接受的对象转发事件。

Timeout

Long

控件的执行脚本的超时值,-1表示不超时

UseSafeSubset

BOOL

设置或返回宿主程序是否关心安全。宿主程序的安全级别可以从此属性设置

Error

Error

错误对象,发生错误时,此属性返回一个错误对象

 

方法名称

参数

功能

AddCode

Code As String

往脚本引擎中加入要执行的脚本

AddObject

Name As String, Object As Object, [AddMembers As Boolean = False]

往脚本引擎加入一个对象,以便在脚本中可以使用该对象提供的方法等 。

Eval

Expression As String

表达式求值

ExecuteStatement

Statement As String

解释并执行脚本语句

Reset

 

丢弃所有的对象和代码,将State属性置0

Run

ProcedureName As String, ParamArray Parameters() As Variant

运行一个指定的过程

 

事件名称

功能

Error

有错误发生时激发该事件

TimeOut

执行过程超时时发生

 

一般使用方法

1、在程序中加入ScriptControl

2、定义一个ScriptControl的实例

3、调用AddCode等方法向脚本引擎中加入要执行的脚本。

4、调用Run执行要执行的脚本函数。

宿主与脚本的通讯

1、  宿主调用脚本:这个过程比较简单,只要调用Run就可以将参数传递到脚本。

2、  脚本调用宿主:在初始化过程中调用AddObject接口,将宿主的一个或多个对象暴露给脚本,这时就可以在脚本中调用宿主 对象的方法。在VC++中这个对象不是普通的C++类,它必须支持自动化,在脚本中也只能调用对象中自动化接口(在VB中这个相对比较单)。

脚本调试

任何人写的代码都不可能一次就很完美,但是脚本由于执行的位置特殊,调试方法也不一样。 首先下载一个脚本调试器(我用的是Microsoft Script Debugger, 网站有下载,另据说其它的如VJ++也可以),安装以后在菜单上没有启动菜单。

调试器的启动

在一般的高级语言中都可以方便的设置断点,但是在启动脚本调试器以前如何开始调试呢?在 IE中脚本出错会自动提示是否调试,还可以在脚本中加入中断 代码(VBScript: Stop JavaScript: debugger,但是在ScriptControl还需要修改一下注册表才可以,你需要将HKEY_CURRENT_USER/Software/Microsoft/Windows Script/Settings下的 JITDebug的值改为1(默认为0

例子

下面是个易语言的例子
.版本 2
.子程序 子程序
CoInitialize (0)
.判断开始 (脚本对象.创建 (“ScriptControl”, ))
.默认
信息框 (“UnOk”, 0, )
.判断结束
.判断开始 (脚本对象.写属性 (“Language”, “javascript”))
.默认
信息框 (“UnOk”, 0, )
.判断结束
脚本对象.方法 (“AddCode”, #JSFunc)
输出调试文本 (脚本对象.取错误 ())
编辑框T.加入文本 (脚本对象.通用方法 (“Run”, “coo”, “cooFunction”).取文本 (), #换行符)
输出调试文本 (脚本对象.取错误 ())
CoUninitialize ()
待续...

线程中调用


API_CoInitialize ()
API_CoUninitialize ()


 

在线程中调用有时候注意可能需要考虑许可区问题,至于为什么暂未弄明白过来,不知道......
在多线程下、需为每条线程创建脚本对象,应该还有其他实现方法,暂未找到,继续努力......
问题:   怎么实现只需创建一次,而在多条线程里面都能调用之,同时不会发生异常现象.......
如果你有好的解决方法,欢迎分享,共同学习,一起进步。
阅读更多

没有更多推荐了,返回首页