ZOJ 3261 Connections in Galaxy War(逆向并查集)

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

  • "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1


思路:刚开始思路是不进行路径压缩,但是这样应该会超时,所以要换种思路。

先将未被破坏的点存储,对查询逆序操作,破坏就变成连接了。


代码:

#include <stdio.h>
#include<string.h>

//f存储父节点,pi存储星球能量,access存储通道信息,refer存储查询信息,ans存储答案
int f[10005],pi[10005],access[20005][3],refer[50005][2],ans[50005];

void init(int n)
{
    int i;
    memset(access,0,sizeof(access));
    memset(refer,-1,sizeof(refer));
    for(i=0;i<n;i++){
        f[i]=i;
        scanf("%d",&pi[i]);
    }
}

int getf(int a)
{
    if(a==f[a])return a;
    return f[a]=getf(f[a]);
}

void merge(int a,int b)
{
    int fa=getf(a),fb=getf(b);
    if(fa==fb)return;
    if(pi[fb]>pi[fa])f[fa]=fb;//使根节点一直为最大值
    else f[fb]=fa;
}

int main()
{
    int n,m,q,i,j,flag=0;
    char s[10];
    while(~scanf("%d",&n))
    {
        init(n); //初始化

        scanf("%d",&m);
        for(i=0;i<m;i++)scanf("%d%d",&access[i][0],&access[i][1]);
        scanf("%d",&q);
        for(i=0;i<q;i++)
        {
            scanf("%s",s);
            if(s[0]=='q')
                scanf("%d",&refer[i][1]);//refer为默认值-1代表查询
            else
            {
                scanf("%d%d",&refer[i][0],&refer[i][1]);
                for(j=0;j<m;j++)//标记被破坏节点
                {
                    if( (access[j][0]==refer[i][0] && access[j][1]==refer[i][1]) || (access[j][1]==refer[i][0] && access[j][0]==refer[i][1]) )
                    {
                        access[j][2]=1;
                        break;
                    }
                }
            }
        }

        for(i=0;i<m;i++)//合并未被破坏的节点
        {
            if(!access[i][2])
                merge(access[i][0],access[i][1]);
        }

        int index=0;
        for(i=q-1;i>=0;i--)//逆序操作
        {
            if(refer[i][0]==-1)
            {
                getf(refer[i][1]);  //使其连接根节点
                if(pi[f[refer[i][1]]]==pi[refer[i][1]])ans[index]=-1;//经过合并的操作,根节点为最大值
                else ans[index]=f[refer[i][1]];
                index++;
            }
            else
            {
                merge(refer[i][0],refer[i][1]);//合并被破坏节点
            }
        }
        if(flag++)printf("\n");
        for(i=index-1;i>=0;i--)printf("%d\n",ans[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
本火锅店点餐系统采用Java语言和Vue技术,框架采用SSM,搭配Mysql数据库,运行在Idea里,采用小程序模式。本火锅店点餐系统提供管理员、用户两种角色的服务。总的功能包括菜品的查询、菜品的购买、餐桌预定和订单管理。本系统可以帮助管理员更新菜品信息和管理订单信息,帮助用户实现在线的点餐方式,并可以实现餐桌预定。本系统采用成熟技术开发可以完成点餐管理的相关工作。 本系统的功能围绕用户、管理员两种权限设计。根据不同权限的不同需求设计出更符合用户要求的功能。本系统中管理员主要负责审核管理用户,发布分享新的菜品,审核用户的订餐信息和餐桌预定信息等,用户可以对需要的菜品进行购买、预定餐桌等。用户可以管理个人资料、查询菜品、在线点餐和预定餐桌、管理订单等,用户的个人资料是由管理员添加用户资料时产生,用户的订单内容由用户在购买菜品时产生,用户预定信息由用户在预定餐桌操作时产生。 本系统的功能设计为管理员、用户两部分。管理员为菜品管理、菜品分类管理、用户管理、订单管理等,用户的功能为查询菜品,在线点餐、预定餐桌、管理个人信息等。 管理员负责用户信息的删除和管理,用户的姓名和手机号都可以由管理员在此功能里看到。管理员可以对菜品的信息进行管理、审核。本功能可以实现菜品的定时更新和审核管理。本功能包括查询餐桌,也可以发布新的餐桌信息。管理员可以查询已预定的餐桌,并进行审核。管理员可以管理公告和系统的轮播图,可以安排活动。管理员可以对个人的资料进行修改和管理,管理员还可以在本功能里修改密码。管理员可以查询用户的订单,并完成菜品的安排。 当用户登录进系统后可以修改自己的资料,可以使自己信息的保持正确性。还可以修改密码。用户可以浏览所有的菜品,可以查看详细的菜品内容,也可以进行菜品的点餐。在本功能里用户可以进行点餐。用户可以浏览没有预定出去的餐桌,选择合适的餐桌可以进行预定。用户可以管理购物车里的菜品。用户可以管理自己的订单,在订单管理界面里也可以进行查询操作。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值