ZOJ 3261 Connections in Galaxy War(逆向并查集)

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

  • "destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

    "query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1


思路:刚开始思路是不进行路径压缩,但是这样应该会超时,所以要换种思路。

先将未被破坏的点存储,对查询逆序操作,破坏就变成连接了。


代码:

#include <stdio.h>
#include<string.h>

//f存储父节点,pi存储星球能量,access存储通道信息,refer存储查询信息,ans存储答案
int f[10005],pi[10005],access[20005][3],refer[50005][2],ans[50005];

void init(int n)
{
    int i;
    memset(access,0,sizeof(access));
    memset(refer,-1,sizeof(refer));
    for(i=0;i<n;i++){
        f[i]=i;
        scanf("%d",&pi[i]);
    }
}

int getf(int a)
{
    if(a==f[a])return a;
    return f[a]=getf(f[a]);
}

void merge(int a,int b)
{
    int fa=getf(a),fb=getf(b);
    if(fa==fb)return;
    if(pi[fb]>pi[fa])f[fa]=fb;//使根节点一直为最大值
    else f[fb]=fa;
}

int main()
{
    int n,m,q,i,j,flag=0;
    char s[10];
    while(~scanf("%d",&n))
    {
        init(n); //初始化

        scanf("%d",&m);
        for(i=0;i<m;i++)scanf("%d%d",&access[i][0],&access[i][1]);
        scanf("%d",&q);
        for(i=0;i<q;i++)
        {
            scanf("%s",s);
            if(s[0]=='q')
                scanf("%d",&refer[i][1]);//refer为默认值-1代表查询
            else
            {
                scanf("%d%d",&refer[i][0],&refer[i][1]);
                for(j=0;j<m;j++)//标记被破坏节点
                {
                    if( (access[j][0]==refer[i][0] && access[j][1]==refer[i][1]) || (access[j][1]==refer[i][0] && access[j][0]==refer[i][1]) )
                    {
                        access[j][2]=1;
                        break;
                    }
                }
            }
        }

        for(i=0;i<m;i++)//合并未被破坏的节点
        {
            if(!access[i][2])
                merge(access[i][0],access[i][1]);
        }

        int index=0;
        for(i=q-1;i>=0;i--)//逆序操作
        {
            if(refer[i][0]==-1)
            {
                getf(refer[i][1]);  //使其连接根节点
                if(pi[f[refer[i][1]]]==pi[refer[i][1]])ans[index]=-1;//经过合并的操作,根节点为最大值
                else ans[index]=f[refer[i][1]];
                index++;
            }
            else
            {
                merge(refer[i][0],refer[i][1]);//合并被破坏节点
            }
        }
        if(flag++)printf("\n");
        for(i=index-1;i>=0;i--)printf("%d\n",ans[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值