Prime Ring Problem--深搜,回溯


C - Prime Ring Problem
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description


A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.





Input

n (0 < n < 20).



Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.



Sample Input

6
8


Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


#include <stdio.h>  //注意!!在每个for循环都要重新定义一遍i,不然无法输出!!
int num[21],mark[21],n;
int prime[12]= {2,3,5,7,11,13,17,19,23,29,31,37}; //12个素数

int is_prime(int a)  //判断是否是素数,如果是就返回1,不是返回0
{
    for(int i=0; i<12; i++)
    {
        if(a==prime[i])return 1;
    }
    return 0;
}
void print_num()   //输出函数,输出num
{
    for(int i=1; i<n; i++)
    {
        printf("%d ",num[i]);
    }
    printf("%d",num[n]);
}
int dfs(int pre,int post,int flag)
{
    if(!is_prime(pre+post)) return 0;  //如果不符合前后两个数相加是素数,则直接退出函数
    num[flag]=post;  //让序号为flag的num数组等于后面的数
    if(flag==n&&is_prime(post+1))   //如果flag等于输入的n并且后面的数加上1仍然是素数,则输出num,结束函数
    {
        print_num();
        printf("\n");
        return 1;
    }
    mark[post]=0;//使用过这个数字就标记为零
    for(int i=2; i<=n; i++)
    {
        if(mark[i]!=0 && dfs(post,i,flag+1)) break;  //从i等于2到n找到没有标记过的数并且回溯调用dfs函数直到输出函数结束返回1,结束

    }
    //标记位恢复原状
    mark[post]=1;
    return 0;

}

int main()
{
    int count;
    count=1;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++) //对标记数组进行初始化,不为零则表明未用过该数
        {
            mark[i]=i;
        }
        num[1]=1;//所有的素数圈都是从1开始的
        printf("Case %d:\n",count++);//格式输出
        if(n==1) printf("1\n");//n为1的特殊情况
        for(int i=2; i<=n; i++)
        {
            dfs(1,i,2);//flag为2是因为是从num【2】开始赋值
        }
        printf("\n");//注意格式!!!!!!!!!!!!!!!!!!

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值