poj 1016 Prime Ring Problem -- 回溯

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40481    Accepted Submission(s): 17872


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int p[21],vis[21];
int n;
int prime(int x){
	if(x==1)
		return 0;
	if(x==2)
		return 1;
	for(int i=2;i<x;i++)
		if(x%i==0)
			return 0;
	return 1;
}
void dfs(int x,int num){
	int i;
	if(x==n&&prime(1+num)){
		for(i=0;i<n-1;i++)
			printf("%d ",p[i]);
		printf("%d\n",p[n-1]);
	}
	for(i=2;i<=n;i++){
		if(!vis[i]&&prime(num+i)){
			vis[i]=1;
			p[x]=i;
			dfs(x+1,i);
			vis[i]=0;
		}
	}
}
int main(){
	int Case=1;
	while(~scanf("%d",&n)){
		printf("Case %d:\n",Case++);
		if(n==1){
			printf("1\n");
			continue;
		}
		if(n%2!=0){
			printf("\n");
			continue;
		}
		memset(vis,0,sizeof(vis));
		p[0]=vis[1]=1;
		dfs(1,1);
		printf("\n");			
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值