POJ - 2774 - Long Long Message(后缀数组)

Long Long Message
Time Limit: 4000MS Memory Limit: 131072K
Total Submissions: 27000 Accepted: 10984
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 
1. The little cat is so busy these days with physics lessons; 
2. The little cat wants to keep what he said to his mother seceret; 
3. POJ is such a great Online Judge; 
4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27

题意:求两个字符串的最长公共子串。

后缀数组的裸题,套套模板就过了。过了裸题心里轻松了一点点,证明模板我还是会套的2333

本来被卿爷误导以后还要这题还要学什么RMQ,瞬间觉得后缀自动机这暑假遥遥无期orz 结果拖了一天才搞掉这道题orzzzzzzzzz

思路:因为sa数组和height都求了,本来求最长前缀只要扫一遍height就好。现在求两个串公共子串,那就先把两个串拼起来,然后只要判断sa[i]和sa[i-1]分别在两个字符串里再算height就好了

第一道后缀数组【捂脸】顺便再记录一下继昨天史上最蠢没写 !=EOF 的wa后,又出现了更蠢的wa,交错题目..........

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <iostream>
#include <assert.h>
#define INF 0x3f3f3f3f
using namespace std;

const int maxn = 4e5 + 10;
const int M = 2e5 + 10;
int w[maxn];
int rankk[M];
int sa[M];
int height[M];
char s[M];

void get_sa_hei(int len)
{
  static int m[maxn], tmp[maxn];
  //int len = strlen(s + 1);  
  memset(rankk, 0, sizeof(int) * len * 2);
  for (int i = 0; i <= 255; i++) w[i] = 0;
  for (int i = 1; i <= len; i++) w[s[i]]++;
  for (int i = 1; i <= 255; i++) w[i] += w[i - 1];
  for (int i = len; i; i--) tmp[w[s[i]]--] = i; 
  rankk[tmp[1]] = 1; 
  for (int i = 2; i <= len; i++)
    rankk[tmp[i]] = rankk[tmp[i-1]] + (s[tmp[i]] != s[tmp[i-1]]);


  //get sa  用基数排序
  for (int k = 1; k <= len; k <<= 1) {
    for (int i = 0; i <= len; i++) w[i] = 0;
    for (int i = 1; i <= len; i++) w[rankk[i+k]]++;
    for (int i = 1; i <= len; i++) w[i] += w[i-1];
    for (int i = len; i; i--) m[w[rankk[i+k]]--] = i;

    for (int i = 0; i <= len; i++) w[i] = 0;
    for (int i = 1; i <= len; i++) w[rankk[i]]++;
    for (int i = 1; i <= len; i++) w[i] += w[i-1];
    for (int i = len; i; i--) tmp[w[rankk[m[i]]]--] = m[i];

    m[tmp[1]] = 1;
    for (int i = 2; i <= len; i++)
      m[tmp[i]] = m[tmp[i-1]] + (rankk[tmp[i]] != rankk[tmp[i-1]] || rankk[tmp[i]+k] != rankk[tmp[i-1]+k]);
    for (int i = 1; i <= len; i++) rankk[i] = m[i];
  }
  for (int i = 1; i <= len; i++) sa[rankk[i]] = i;


  //get height
  for (int i = 1, j = 0; i <= len; i++) {
    if (rankk[i] == 1) continue;
    for (j ? j-- : 0; s[sa[rankk[i]-1]+j] == s[i+j]; j++);
    height[rankk[i]] = j;
  }
}

char s1[M];
int main()
{
  while (scanf("%s%s", s + 1, s1) != EOF) {
    int len = strlen(s + 1);
    int x = len;
    s[++len] = '*'; 
    for (int i = 0; s1[i]; i++) {
      s[++len] = s1[i];
    }
    get_sa_hei(len); 
    int mmax = 0;
    for (int i = 2; i <= len; i++) {
      if (height[i] < mmax) continue;
      if (sa[i] > 0 && sa[i] <= x && sa[i - 1] > x) mmax = height[i];
      if (sa[i - 1] > 0 && sa[i - 1] <= x && sa[i] > x) mmax = height[i];
    }
    printf("%d\n", mmax);
  }
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值