AOJ-AHU-OJ-36 (POJ-2033) Alphacode

80 篇文章 0 订阅
69 篇文章 0 订阅
Alphacode
Time Limit: 1000 ms   Case Time Limit: 1000 ms   Memory Limit: 64 MB
Description
Alice and Bob need to send secret messages to each other and are discussing ways to encode their
messages:
Alice: “Let’s just use a very simple code: We’ll assign ‘A’ the code word 1, ‘B’ will be 2, and so on down to ‘Z’ being assigned 26.”
Bob: “That’s a stupid code, Alice. Suppose I send you the word ‘BEAN’ encoded as 25114.
You could decode that in many different ways!”
Alice: “Sure you could, but what words would you get? Other than ‘BEAN’, you’d get ‘BEAAD’, ‘YAAD’, ‘YAN’, ‘YKD’ and ‘BEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?”
Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.”
Alice: “How many different decodings?”
Bob: “Jillions!”
For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input
Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of ‘0’ will terminate the input and should not be processed.

Output
For each input set, output the number of possible decodings for the input string. All answers will be within the range of a 32-bits unsigned integer variable.

Sample Input
Original Transformed
25114
1111111111
3333333333
0

Sample Output
Original Transformed
6
89
1
————————————————————山寨的分割线————————————————————
思路:据说是DP……不懂什么是DP,但是的确是递推。首先我们考虑解码方式:一个数字或者两个数字构成一个字母。那么显而易见,对于每一个数字,只有两种解码:单独解码 or 结合前一个数字解码。而且,每完成前 2 个数字的解码,之后每增加一个数字,总的解码方式就可以从前两个推出来。我们应该保存前两个数字下的总解码方式。由此我们可以得到状态转移方程:
不可结合前一个数字:dp[i] = dp[i-1]
可结合前一个数字:  dp[i] = dp[i-1] + dp[i-2]
之后再考虑一个问题:数字段中出现0。跟其他的数字不同,0不能够单独解码,只要它存在,那就必须和它前面的数字结合,否则数据无意义。这就需要一个字符串->数字的转换。
代码如下:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#define JUD num[i-1] < 10 && num[i] < 10 && num[i-1]*10 + num[i] <= 26
int main(){
    char s[5000];
    int num[5000];
    long long dp0, dp1, dp2;//节省空间,不必保存成数组,暂存三个即可
    while(scanf("%s", s + 1), s[1]!='0') {
        int len = strlen(s + 1);
        int j = 1;
        for(int i = 1; i <= len; i++) {
            if(s[i] == '0') {
                j--;
                num[j] = num[j] * 10;//与前一个数字结合
                j++;
            }
            else
            num[j++] = s[i] - '0';
        } //完成字符串向数字的转换,处理了中间的0
        dp0 = 1; dp1 = 1;
        for(int i = 2; i < j; i++) {
            dp2 = dp1;
            if(JUD) dp2 += dp0; //注意!深坑!一旦数据中有10、20这种数字,解码的时候就必须“单独”解码。比如:1102
            dp0 = dp1;
            dp1 = dp2;//递推
        }
        printf("%lld\n", dp2);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值