POJ 3463 Sightseeing (最短路与次短路)

 

Sightseeing
Time Limit: 2000MS  Memory Limit: 65536K
Total Submissions: 6312  Accepted: 2228

Description

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

  • M lines, each with three integers AB and L, separated by single spaces, with 1 ≤ AB ≤ NA ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

    The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

  • One line with two integers S and F, separated by a single space, with 1 ≤ SF ≤ N and S ≠ F: the starting city and the final city of the route.

    There will be at least one route from S to F.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

Sample Input

2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output

3
2

Hint

The first test case above corresponds to the picture in the problem description.

Source

 

 

题意:旅行团每天固定的从S地出发到达T地,为了省油要求尽量走最短路径或比最短路径长1单位距离的路径,求满足条件的路径条数

算法:最短路和次短路。Dijkstra算法。采用邻接表建图。

总结:不要用邻接矩阵。因为有重边。

 

dis[x][2]:dis[x][0]表示起点到x的最短路、dis[x][1]表示起点到x的次短路;

arr[x][2]:arr[x][0]表示起点到x的最短路条数、arr[x][1]表示起点到x的次短路的条数;

vis[x][2]对应于x和0、1功能为记录该点是否被访问!

     那么如何更新最小和次小路呢?显然我们容易想到下面的方法:

      1.if(x<最小)更新最小,次小;
      2.else if(x==最小)更新方法数;
      3.else if(x<次小)更新次小;
      4.else if(x==次小)更新方法数;

     最后说说dijkstra的循环部分、这也是本题的关键。为什么我们要循环2*nnum-1次?显然这道题中我们每一条边都需要考虑、这不是在求最短的一条,说白了是让你求出所有的可能组合,那么我们势必对每一种情况都需要遍历一次,虽然中间有重复。最短路里已知[start][0]已被标记为访问过,那么就只有nnum-1次遍历了,而次短路我们则需要遍历nnum次,这样两者加起来就为2*nnum-1次。这与我们平时使用优先队列+heap是一样的。只是更加细化了而已。

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int VM=1010;
const int EM=10010;
const int INF=0x3f3f3f3f;

struct Edge{
    int to,nxt;
    int cap;
}edge[EM<<1];

int n,m,cnt,head[VM];
int count[VM][2],dis[VM][2],vis[VM][2]; // dis[i][0]:到点i的最短路   dis[i][1]:到点j的次短路
                                        // count[i][0]:到点i的最短路的路数   count[i][1]:到点j的次短路的路数
int src,des;

void addedge(int cu,int cv,int cw){
    edge[cnt].to=cv;    edge[cnt].cap=cw;   edge[cnt].nxt=head[cu];
    head[cu]=cnt++;
}

void Dijkstra(){
    memset(vis,0,sizeof(vis));
    memset(count,0,sizeof(count));
    int i;
    for(i=1;i<=n;i++){
        dis[i][0]=INF;
        dis[i][1]=INF;
    }
    dis[src][0]=0;
    count[src][0]=1;
    //vis[src][0]=1;        //依然不用,,为啥呢?
    int j,k,tmp,flag;
    for(i=1;i<2*n;i++){
        tmp=INF;            // 找新的最短路和次短路
        for(j=1;j<=n;j++)
            if(!vis[j][0] && tmp>dis[j][0]){
                k=j;
                flag=0;
                tmp=dis[j][0];
            }else if(!vis[j][1] && tmp>dis[j][1]){
                k=j;
                flag=1;
                tmp=dis[j][1];
            }
        if(tmp==INF)    // 如果最短路和次短路都不存在,则退出for循环
            break;
        vis[k][flag]=1;
        for(j=head[k];j!=-1;j=edge[j].nxt){     // 更新和点k相连的边
            int v=edge[j].to;
            if(dis[v][0]>tmp+edge[j].cap){      // 比最短路短
                dis[v][1]=dis[v][0];
                count[v][1]=count[v][0];
                dis[v][0]=tmp+edge[j].cap;
                count[v][0]=count[k][flag];
            }else if(dis[v][0]==tmp+edge[j].cap)    // 等于最短路
                count[v][0]+=count[k][flag];
            else if(dis[v][1]>tmp+edge[j].cap){     // 比次短路短
                dis[v][1]=tmp+edge[j].cap;
                count[v][1]=count[k][flag];
            }else if(dis[v][1]==tmp+edge[j].cap)    // 等于次短路
                count[v][1]+=count[k][flag];
        }
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        cnt=0;
        memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&m);
        int u,v,w;
        while(m--){
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
        }
        scanf("%d%d",&src,&des);
        Dijkstra();
        int ans=count[des][0];
        if(dis[des][1]==dis[des][0]+1)
            ans+=count[des][1];
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值