PAT--1094 The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4
#include <iostream>
#include <bits/stdc++.h>

using namespace std;
struct TreeNode
{
    int layer;
    vector<int> child;
} t[110];

int n,m;
int LevelCount[110];
int maxLevel = 1,maxSize = 1;
int main()
{
    cin>>n>>m;
    //int father[n+1];
    //memset(father,-1,sizeof(father));
    int id,k,child;
    int root;
    for(int i=0; i<m; i++)
    {
        cin>>id>>k;
        for(int j=0; j<k; j++)
        {
            cin>>child;
           // father[child] = id;
            t[id].child.push_back(child);
        }
    }


  root = 1;
    queue<int> q;
    t[root].layer = 1;
    q.push(root);
    LevelCount[t[root].layer]++;
    int top;
    while(!q.empty()){
        top = q.front();
        q.pop();
        for( int i=0;i<t[top].child.size();i++){
            int child = t[top].child[i];
            t[child].layer = t[top].layer+1;
            LevelCount[t[child].layer]++;
            if(LevelCount[t[child].layer]>maxSize){
                maxSize = LevelCount[t[child].layer];
                maxLevel = t[child].layer;
            }
            q.push(child);
        }
    }

    cout<<maxSize<<" "<<maxLevel<<endl;
}

 注:

注意maxLevel,maxSize 的值,应都为1,因为题目规定其根节点为第一层,若是设为0,则在只有一个根节点的时候答案错误(因为这错了好几次);还有题目说明结点1为根结点,因为没有认真看题,所以我最开始还用并查集查找根节点,出现段错误(不知道为什么)。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值