Hdu1969-Pie-【二分】

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1969


Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13624    Accepted Submission(s): 4852


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:  1551 2199 2899 2446 2298 
 

题意:N块饼,F个朋友,还有自己;每个人分得一块相同分量的饼,不能由几小块凑成,求能分成的最大体积/面积

解题:求出来最大面积,,算出来可分得最大面积,然后从小到大找符合的,

精度:要求高,pi要用反余弦pi=acos(-1.0);

#include<cstdio>
#include<cmath>
#include<algorithm>
#define PI acos(-1.0)  //求 π 
int N,F;
double len[10010];
bool Get(double x)
{
	int num = 0;
	for(int i = 0; i < N; i++)
	{
		num+=(int)(len[i]/x);//没 int WA了好多次 
	}
	if(num >= F+1)  //判断是否够分的 
		return true;
	else
		return false;
}
int main()
{
	int T;
	double sum,r,l,mid;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&N,&F);
		sum=0;
		for(int i = 0; i < N; i++)
		{
			scanf("%lf",&len[i]);
			len[i] = len[i]*len[i]*PI;
			sum+=len[i];			//总的面积 
		}
		r = (double)sum/(F+1);  //分的最大面积 再大就不够分 
		l = 0.0;
		while(r-l>1e-6)
		{
			mid = (double)(r+l)/2;
			if(Get(mid))
				l = mid;  //能分开 则往大的找 
			else
				r = mid;
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值