POJ - 3278 Catch That Cow

POJ - 3278 Catch That Cow

题目

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题解

bfs,但是不是在一个图里面,这题每次状态都要自己手动计算。

/*************************************************************************
    > Problem: POJ - 3278 Catch That Cow
    > Author: ALizen_
    > Mail: hhu_zyh@qq.com
    > Blog: https://blog.csdn.net/Jame_19?spm=1001.2101.3001.5343
*************************************************************************/
#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define re register int
#define sf(x) scanf("%d",&x)
#define pf(x) printf("%d\n",x)
#define slf(x) scanf("%lld",&x)
#define plf(x) printf("%lld\n",x)
#define MEM(a,b) memset((a),(b),sizeof(a))
#define ref(i,a,b) for(re i = a ; i >= b ; -- i)
#define fer(i,a,b) for(re i = a ; i <= b ; ++ i)
using namespace std;
typedef long long LL;
int n,k,ans;
int book[1000000];
struct node{
	int x,step;
}; 
node now,next,start;
void bfs(){
	queue<node> q;
	q.push(start);
	while(q.size()){
		now=q.front();
		q.pop();
		if(now.x==k){
			printf("%d",now.step);
			return;
		}
		for(int i=0;i<3;i++){
			if(i==0){
				next.x=now.x+1;
			}
			else if(i==1){
				next.x=now.x-1;
			}
			else if(i==2){
				next.x=now.x*2;
			}
			next.step=now.step+1;
			if(book[next.x]==0&&next.x>=0&&next.x<100005){
				q.push(next);
				book[next.x]=1;
			}
		}
	}
}
int main(){
	scanf("%d%d",&n,&k);
	memset(book,0,sizeof(book));
	book[n]=1;
    start.step=0;
    start.x=n;
    bfs();


    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值