Idea Error:java: 无效的目标发行版: 12

电脑系统jdk用的1.8.0_201版本
报错如图示:
在这里插入图片描述

按照IDEA ‘Error:java: 无效的源发行版: 10’ 解决方案给出的解决方案,查看Project Language Level配置没有问题
在这里插入图片描述

继续检查配置,发现settings—>Java Compiler——>Target byteCode version配置的是12,终于找到你啦!
在这里插入图片描述
将这个配置改为8,重新运行程序,正常啦~
在这里插入图片描述

出现这个问题的原因:
之前解决不能维持IntelliJ 之 Target bytecode Version版本号,为了方便,pom.xml模板中配置了compiler版本为12,生成项目后,在pom.xml文件中将12改成1.8后,settings中的Target byteCode version没有同步修改过来,导致出现上面的问题。
在这里插入图片描述

  • 3
    点赞
  • 2
    评论
  • 7
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

打赏
文章很值,打赏犒劳作者一下
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页

打赏

jamieblue1

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者