HOJ1020

Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8388 Accepted Submission(s): 3490


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.



Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.



Output
For each test case, output the encoded string in a line.



Sample Input
2
ABC
ABBCCC


Sample Output
ABC
A2B3C


Author
ZHANG Zheng


Recommend
JGShining


#include<iostream>
#include<string>
using namespace std;

void main() {
int n;
string s;
int i,j,count;
cin>>n;
for(i=0; i<n; i++) {
count = 1;
cin>>s;
for(j=1; j<s.length(); j++) {
if(s[j-1] != s[j]) {
if(count == 1)
cout<<s[j-1];
else
cout<<count<<s[j-1];
if(j == s.length()-1)
cout<<s[j];
count = 1;
} else {
count++;
if(j == s.length()-1)
cout<<count<<s[j];
}
}
cout<<endl;
}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值