1084. Broken Keyboard (20)
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.
Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.
Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.
Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:7_This_is_a_test _hs_s_a_esSample Output:
7TI
1029. 旧键盘(20)
旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。
输入格式:
输入在2行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过80个字符的串,由字母A-Z(包括大、小写)、数字0-9、以及下划线“_”(代表空格)组成。题目保证2个字符串均非空。
输出格式:
按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有1个坏键。
输入样例:7_This_is_a_test _hs_s_a_es输出样例:
7TI
提交代码
#include<stdio.h>
#include<string.h>
bool hashTable[128]={false};
int main()
{
char s1[100], s2[100];
gets(s1);
gets(s2);
int len1=strlen(s1);
int len2=strlen(s2);
for(int i=0;i<len1;i++)
{
char c1=s1[i],c2;
int j;
for(j=0;j<len2;j++)
{
c2=s2[j];
if(c1>='a'&&c1<='z')
{
c1-=32;
}
if(c2>='a'&&c2<='z')
{
c2-=32;
}
if(c1==c2) break;
}
if(j==len2&&hashTable[c1]==false)
{
printf("%c",c1);
hashTable[c1]=true;
}
}
return 0;
}