POJ-1042-贪心+枚举+优先队列

Gone Fishing
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 28410 Accepted: 8495

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

题目的意思说起来比较绕口,可以自行理解(谷歌翻译,百度翻译,有道翻译......),这个题目稍微有点难度,
可能刚开始想比较难想到,但是只要稍微提醒下估计就会明吧。我们可以枚举他的终点是在某个池塘,计算出以该池塘为终点所能得到的最多的鱼(用
总时间减去路上花掉的时间,即为在池塘钓鱼的时间,每次都是取能够钓到数量多的池塘,时间有多就把剩余的时间直接加在第一个
池塘的时间),一直枚举下去,就可以得到最多能得到多少鱼。
看代码应该能够更加好理解吧:

//枚举+优先队列+贪心
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<algorithm>
using namespace std;
struct P
{
    int ff;   //每次能钓到的鱼
    int dd;   //每五分钟减少量
    int x;   //记录下标
    friend bool operator<(P a,P b)
    {
        if(a.ff==b.ff) return a.x>b.x;   //如果能够钓到的鱼的数量一样多,那么取前面的池塘
        return a.ff<b.ff;                //取能够钓到的鱼数量多的池塘
    }
};
int main()
{
     int n;
     int first=-1;
     while(scanf("%d",&n)!=EOF&&n!=0)
     {
         first++;
         int h;
         int f[30],d[30],t[30];
         scanf("%d",&h);
         for(int i=0;i<n;i++){
            scanf("%d",&f[i]);
         }
         for(int i=0;i<n;i++){
            scanf("%d",&d[i]);
         }
         for(int i=1;i<n;i++){
            scanf("%d",&t[i]);
         }
         h=h*60;
         t[0]=0;
         int ans=-1;
         int lake[30],lake0[30];
         memset(lake,0,sizeof(lake));
         priority_queue<P>q;
         for(int i=0;i<n;i++)   //枚举
         {
             int sum=0;
             h-=t[i]*5;
             int time=h;
             memset(lake0,0,sizeof(lake0));
             for(int j=0;j<=i;j++)
             {
                 P g;
                 g.ff=f[j];
                 g.dd=d[j];
                 g.x=j;
                 q.push(g);
             }
             while(q.size())
             {
                 P p=q.top();
                 q.pop();
                 if(time>0&&p.ff>0)
                 {
                     sum+=p.ff;
                     time-=5;
                     p.ff-=p.dd;
                     lake0[p.x]+=5;
                     q.push(p);
                 }
             }
             lake0[0]+=time;
             if(sum>ans){
                ans=sum;
                for(int k=0;k<=i;k++)
                    lake[k]=lake0[k];
             }
         }
         if(first) printf("\n");
         for(int i=0;i<n;i++)
         {
             if(i==0) printf("%d",lake[i]);
             else     printf(", %d",lake[i]);
         }
         printf("\nNumber of fish expected: %d\n",ans);
     }return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值