POJ-3126-宽搜+素数筛选

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11379 Accepted: 6448

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

Northwestern Europe 2006

该题目先打个素数表,因为求最小步数,很自然就想到了宽搜了。该题对该四位数的每一位进行操作。具体看代码:
#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=10000;
void divide(int nn,int mm[])
{
    int chu=1000;
    for(int i=0;i<4;i++)
    {
        mm[i]=nn/chu;
        nn=nn%chu;
        chu/=10;
    }
}
int main()
{
    bool vis[maxn];
    memset(vis,true,sizeof(vis));
    vis[0]=vis[1]=false;
    for(int i=2;i*i<=10000;i++)       //素数筛选
    {
        if(vis[i])
        {
            for(int j=i*i;j<=10000;j+=i)
                vis[j]=false;
        }
    }
    int t;
    scanf("%d\n",&t);
    while(t--)
    {
        int m,n;
        scanf("%d%d",&m,&n);
        int num[4];
        int nnn[4];
        int d[maxn];
        int dd[maxn];
        queue<int>q;
        q.push(m);
        memset(d,0,sizeof(d));
        memset(dd,0,sizeof(dd));
        dd[m]=1;
        while(q.size())
        {
            int p=q.front(); q.pop();
            if(p==n) break;
            divide(p,num);
            for(int i=0;i<4;i++)
            {
                for(int k=0;k<4;k++)
                    nnn[k]=num[k];
                    
                for(int j=(i==0)?1:0;j<10;j++)
                {
                    if(j==num[i]) continue;
                    nnn[i]=j;
                    int ss=nnn[0]*1000+nnn[1]*100+nnn[2]*10+nnn[3];
                    if(vis[ss]&&dd[ss]==0)
                    {
                        dd[ss]=1;
                        d[ss]=d[p]+1;
                        q.push(ss);
                    }
                }
            }
        }
        int sd=0;
        if(d[n]>0 || m==n) sd=1;  
        if(sd)   printf("%d\n",d[n]);
        else     printf("Impossible\n");
    }return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值