POJ_3262_Protecting the Flowers(greedy)

Protecting the Flowers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4950 Accepted: 1975

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroysDi (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cowi to its barn requires 2 × Ti minutes (Ti to get there andTi to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N
Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Hint

FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.

题意:农夫养的N头牛在他的花园里吃花!这让农夫很苦恼,他一次只能把一头牛赶回牛栏,现在给你赶回每头牛到牛栏的时间Ti(也就是说来回要2*Ti的时间),以及这只牛每分钟能吃掉花的数量Di,求这些牛最少能吃掉多少花。

分析:贪心题。我们拿出两头牛a,b来考虑。若先把牛a赶走,那么吃掉的花的数量是2*(Ta)*(Db);若先把牛b赶回牛栏,那么吃掉花的数量是2*(Tb)*(Da)。所以最优化原则就是取min(2*(Ta)*(Db),2*(Tb)*(Da))。以此类推,贪心规则就出来了,按照此方法sort一遍就行了。

题目链接: http://poj.org/problem?id=3262

代码清单:
#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int uint;

const int maxn = 100000 + 5;
const int maxv = 200000 + 5;

struct Point{
    int T;
    int D;
}point[maxn];

int N;

bool cmp(Point a,Point b){
    return a.D*b.T>a.T*b.D;
}

void input(){
    scanf("%d",&N);
    for(int i=0;i<N;i++){
        scanf("%d%d",&point[i].T,&point[i].D);
    }
}

void solve(){
    sort(point,point+N,cmp);
    ll ans=0,t=0;
    for(int i=0;i<N;i++){
        ans=ans+(ll)point[i].D*t;
        t=t+(ll)(2*point[i].T);
    }
    printf("%I64d\n",ans);
}

int main(){
    input();
    solve();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值