uva_247_Calling Circles(floyd传递闭包)

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Status

Description

If you've seen television commercials for long-distance phone companies lately, you've noticed that many companies have been spending a lot of money trying to convince people that they provide the best service at the lowest cost. One company has calling circles." You provide a list of people that you call most frequently. If you call someone in your calling circle (who is also a customer of the same company), you get bigger discounts than if you call outside your circle. Another company points out that you only get the big discounts for people in your calling circle, and if you change who you call most frequently, it's up to you to add them to your calling circle.

LibertyBell Phone Co. is a new company that thinks they have the calling plan that can put other companies out of business. LibertyBell has calling circles, but they gure out your calling circle for you. This is how it works. LibertyBell keeps track of all phone calls. In addition to yourself, your calling circle consists of all people whom you call and who call you, either directly or indirectly.For example, if Ben calls Alexander, Alexander calls Dolly, and Dolly calls Ben, they are all within the same circle. If Dolly also calls Benedict and Benedict calls Dolly, then Benedict is in the same calling circle as Dolly, Ben, and Alexander. Finally, if Alexander calls Aaron but Aaron doesn't call Alexander, Ben, Dolly, or Benedict, then Aaron is not in the circle.You've been hired by LibertyBell to write the program to determine calling circles given a log of phone calls between people.

Input
The  input  file  will  contain  one  or  more  data  sets.   Each  data  set  begins  with  a  line  containing  two integers,n and m.The first integer,n, represents the number of different people who are in the data set.  The maximum value for
n is 25.  The remainder of the data set consists of m lines, each representing a phone call.  Each call is represented by two names, separated by a single space.  Names are rst names only (unique within a data set), are case sensitive, and consist of only alphabetic characters; no name is longer than 25 letters.
For example, if Ben called Dolly, it would be represented in the data file as
Ben Dolly
Input is terminated by values of zero (0) for n and m.

Output
For each input set,  print a header line with the data set number,  followed by a line for each calling circle in that data set.  Each calling circle line contains the names of all the people in any order within the circle, separated by comma-space (a comma followed by a space).  Output sets are separated by blank lines.

Sample Input
5 6
Ben Alexander
Alexander Dolly
Dolly Ben
Dolly Benedict
Benedict Dolly
Alexander Aaron
14 34
John Aaron
Aaron Benedict
Betsy John
Betsy Ringo
Ringo Dolly
Benedict Paul
John Betsy
John Aaron
Benedict George
Dolly Ringo
Paul Martha
George Ben
Alexander George
Betsy Ringo
Alexander Stephen
Martha Stephen
Benedict Alexander
Stephen Paul
Betsy Ringo
Quincy Martha
Ben Patrick
Betsy Ringo
Patrick Stephen
Paul Alexander
Patrick Ben
Stephen Quincy
Ringo Betsy
Betsy Benedict
Betsy Benedict
Betsy Benedict
Betsy Benedict
Betsy Benedict
Betsy Benedict
Quincy Martha
0 0

Sample Output
Calling circles for data set 1:
Ben, Alexander, Dolly, Benedict
Aaron
Calling circles for data set 2:
John, Betsy, Ringo, Dolly
Aaron
Benedict
Paul, George, Martha, Ben, Alexander, Stephen, Quincy, Patrick

题意:如果两个人互相打电话(直接或者间接),则说他们在同一个电话圈里。例如,a打给b,b打给c,c打给d,d打给a,则这四个人在同一个圈里;如果e打给f,而f不打给e,则不能推出e和f在同一个电话圈。输入n(n<=25)个人的m次电话,找出所有的电话圈。人名只包含字母,不超过25个字符,且不重复。

分析:本题一看就是求有向图的强连通分量问题。可以用tarjan解决。但是注意到数据比较小,还可以想到另外一个算法——floyd。在有向图中,有时不必关心路径的长度,只关心每两点之间是否有通路,则可以用1和0表示“连通”和“不连通”。这样,就可以用floyd解决了:dp[i][j]=dp[i][j]||(dp[i][k]&&dp[k][j])。这样的结果称为有向图的传递闭包(Transitive Closure)。

题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=20840

代码清单:

floyd算法

#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

typedef long long ll;
typedef unsigned int uint;
typedef unsigned long long ull;

const int maxs = 25 + 5;
const int maxn = 2000 + 5;
const int maxv = 4000000 + 5;

int n,m,cases=0;
int dp[maxs][maxs];
int idx1,idx2,cnt;
string name1,name2;
string rstr[maxs];
map<string,int>idx;
bool vis[maxs];

void init(){
    cnt=0; idx.clear();
    memset(dp,0,sizeof(dp));
    memset(vis,false,sizeof(vis));
}

int get_idx(string name){
    if(idx.count(name)) return idx[name];
    idx[name]=++cnt; rstr[cnt]=name;
    return cnt;
}

void input(){
    for(int i=1;i<=m;i++){
        cin>>name1>>name2;
        idx1=get_idx(name1);
        idx2=get_idx(name2);
        dp[idx1][idx2]=1;
    }
}

void floyd(){
    for(int k=1;k<=n;k++){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++)
                dp[i][j]=dp[i][j]||(dp[i][k]&&dp[k][j]);
        }
    }
}

void solve(){
    floyd();
    if(cases) cout<<endl;
    printf("Calling circles for data set %d:\n",++cases);
    for(int i=1;i<=n;i++){
        if(vis[i]) continue;
        cout<<rstr[i];
        for(int j=i+1;j<=n;j++){
            if(vis[j]) continue;
            if(dp[i][j]&&dp[j][i]){
                vis[j]=true;
                cout << ", " <<rstr[j];
            }
        }cout<<endl;
    }
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0) break;
        init();
        input();
        solve();
    }return 0;
}

tarjan算法

#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

typedef long long ll;
typedef unsigned int uint;
typedef unsigned long long ull;

const int maxs = 25 + 5;

int n,m,cases=0;
int idx1,idx2,cnt;
string name1,name2;
string rstr[maxs];
map<string,int>idx;

int sccno,no;
int dfn[maxs];
int low[maxs];
bool InStack[maxs];
stack<int>sta;
vector<int>graph[maxs];

void init(){
    cnt=no=0;
    idx.clear();
    for(int i=0;i<maxs;i++){
        dfn[i]=low[i]=0;
        InStack[i]=false;
        graph[i].clear();
    }
    while(!sta.empty()) sta.pop();
}

int get_idx(string name){
    if(idx.count(name)) return idx[name];
    idx[name]=++cnt; rstr[cnt]=name;
    return cnt;
}

void input(){
    for(int i=1;i<=m;i++){
        cin>>name1>>name2;
        idx1=get_idx(name1);
        idx2=get_idx(name2);
        graph[idx1].push_back(idx2);
    }
}

void tarjan(int u){
    low[u]=dfn[u]=++no;
    InStack[u]=true; sta.push(u);
    for(int i=0;i<graph[u].size();i++){
        int v=graph[u][i];
        if(!dfn[v]){
            tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(InStack[v]){
            low[u]=min(low[u],dfn[v]);
        }
    }
    if(low[u]==dfn[u]){
        int vv=-1;
        while(!sta.empty()&&vv!=u){
            vv=sta.top();
            sta.pop();
            InStack[vv]=false;
            if(vv==u) cout<<rstr[vv]<<endl;
            else cout<<rstr[vv]<<", ";
        }
    }
}

void solve(){
    if(cases) cout<<endl;
    printf("Calling circles for data set %d:\n",++cases);
    for(int i=1;i<=n;i++){
        if(!dfn[i]) tarjan(i);
    }
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        if(!n&&!m) break;
        init();
        input();
        solve();
    }return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值