Xcode8 升级Ruby 升级Cocoapods,遇到的坑及解决办法。

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/jhy835239104/article/details/52655122

20161031 注:taobao 的 ruby 镜像已经失效,替补方案详情见
Ruby China 的 RubyGems 镜像上线


废话不多说直接上错误

No binary rubies available for: osx/10.12/x86_64/ruby-2.2.4.
Continuing with compilation. Please read ‘rvm help mount’ to get more information on binary rubies.


我的安装源本来是淘宝的镜像 https://ruby.taobao.org
结果怎么升级 安装都不好使。据说 Xcode8 以后需要Ruby 版本在2.2以上?
我的版本还是2.0呢。这得想办法升级啊,我用RVM + 淘宝源 总是提示错误(错误提示找不到了)

Can’t install pods on Xcode 8 #5872找到了最后的一个解答,换成原地址https://rubygems.org/
但是我这还是不行,这时候我认为是淘宝源的问题,我得先更换成原版地址,挂个VPN继续。
更换命令
删除淘宝源
$gem source -r https://ruby.taobao.org to remove
添加原版源
$gem source -a https://rubygems.org/ to read
使用$gem sources -l 查看以下确保只有一个https://rubygems.org/源存在
*** CURRENT SOURCES ***
https://rubygems.org
然而因为之前的错误让我有点着急,我并没有按常理出牌,没有直接使用RVM 对Ruby进行升级,我是现在的源码
官方下载地址(截至到20160924 23:59分最稳定版本为Ruby 2.3.1)
ruby-china.org镜像下载地址(国内下载速度快)
下载好源码后,解压在控制台cd进源码文件夹根目录使用命令进行安装
$ ./configure
$ make
$ sudo make install

大概是这样婶儿的
./configure
下面还有很多不都截图了,有很多 no 我也没在意。
接下来是$make
make
依然很长,不全截图了,最后是$ sudo make install
sudo make install
全部完成之后 使用$ruby -v 看一下当前Ruby版本
$ ruby -v
ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin16]
我这还是 2.0.0 ,我一琢磨不对呀,安装应该成功了。
使用命令删掉当前能看见的版本 rvm remove ruby 后面接你查看的版本号
$rvm remove ruby 2.0.0p648
ruby-2.0.0p648 - #already gone 删除成功
再次查看版本号
$ ruby -v
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin16]
好嘞,刚装的 2.3.1 这算是上位了。
抓紧时间,离胜利就差一步了
$sudo gem install cocoapods --pre
又报错
ERROR: While executing gem ... (Gem::Exception)
Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
or 前面让安装OpenSSL 重新build ruby,or后面是让使用 http 别用https。
先看一下 $openssl version 是不是安装了 OpenSSL
OpenSSL 0.9.8zh 14 Jan 2016 恩,有版本,还挺新的
那就更换源 的地址
删除 https 源
$gem source -r https://rubygems.org/ to remove
添加 http 源
$gem source -a http://rubygems.org/ to read
确保添加正确
$gem source
*** CURRENT SOURCES ***
http://rubygems.org/
见证奇迹的时刻
$sudo gem install cocoapods --pre

终于顺利进行了
install cocoapods
这需要一段时间
待安装成功后,验证一下
$pod --version
1.1.0.rc.2

升级成功

如果还有什么疑问可以留言,能帮到你是我的荣幸。(搞了好几个小时,这肩周炎太疼了。。)


20161101 补充

最近更换镜像源地址又出了问题

折腾了半天,也不知道哪个步骤管用了,反正是解决了
展示一下当前正常环境下的各个版本号吧。
rvm版本
使用 ruby 中国的源需要 gem 2.6.X以上版本
升级命令
gem update --system=2.6.3
gem

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页