A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29288 Accepted: 10043

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

哎~,一开始题目都没看懂,有道也是个坑,翻译的还是不能理解,最后在别人的结题报告中才发现好简单!一道简单的DFS题;题意大致就是再不走重复的格子下走完所有的方格,并找出路径。要求以字典序输出!代码如下:
#include<stdio.h>
#include<string.h>
int p,q,way[100][2]={0},vis[10][10],tot,rear;
int dx[8]={-2,-2,-1,-1,1,1,2,2};
int dy[8]={-1,1,-2,2,-2,2,-1,1};// 方向数组
int DFS(int tot,int rear,int x,int y)
{
int i,nx,ny;
if(rear==tot)return 1;// 当搜索的步骤和格子总数相等时,返回1,表示搜索结束;
else for(i=0;i<8;i++)
{
nx=x+dx[i];ny=y+dy[i];
if(nx>=0&&nx<q&&ny>=0&&ny<p&&!vis[nx][ny])
{
vis[nx][ny]=1;// 标记已走过的坐标,以免重复计算;
if(DFS(tot,rear+1,nx,ny))
{
way[rear][0]=nx;way[rear][1]=ny;// 记录下一个格子的坐标,以便输出;
return 1;
}
vis[nx][ny]=0;
}
}
return 0;
}
int main()
{
int n,i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
vis[0][0]=1;
scanf("%d%d",&p,&q);
printf("Scenario #%d:\n",i);
if(DFS(p*q,1,0,0))
{
for(j=0,tot=p*q;j<tot;j++)
printf("%c%d",way[j][0]+'A',way[j][1]+1);
putchar('\n');
}
else printf("impossible\n");
if(i!=0)putchar('\n');
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值