骑士的旅行

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意要求骑士遍历棋盘上的每一个点可以从任意一个点开始但要求输出的路径字典序最小(纵向用大写字母表示)这就要求我们在坐标的移动时也要先向小的坐标开始移动。(怎么说通过这个题对深搜也是有了点认识回溯并不一定要返回值,而是是否经过该点的回溯终止条件可以通过一个标记变量来实现)

#include <iostream>
#include <cstdio>
#include <string.h>
#include <string>
#include <algorithm>
using namespace std;
int m,n,s=0,a[90][90],ax[8]={-1,1,-2,2,-2,2,-1,1},ay[8]={-2,-2,-1,-1,1,1,2,2},falg=0;
int b[90][2];
void dfs(int x,int y,int c)
{
    b[c][1]=y;
    b[c][0]=x;
    if(c==m*n)
    {
        falg=1;
        return;
    }
    for(int i=0;i<8;i++)
    {
        int x1=x+ax[i];
        int y1=y+ay[i];
        if(x1>=1&&y1>=1&&x1<=m&&y1<=n&&!a[x1][y1]&&!falg)
        {
            a[x1][y1]=1;
            dfs(x1,y1,c+1);
            a[x1][y1]=0;
        }
    }
}
int main()
{
    int u,l=0;
    cin>>u;
    while(u--)
    {
        falg=0;
        s++;
        cin>>m>>n;
        memset(a,0,sizeof(a));
        a[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",s);
        if(falg)
        {
            for(int i=1;i<=m*n;i++)
                cout<<(char)(b[i][1]+'A'-1)<<b[i][0];
            cout<<endl;
        }
        else
        {

            cout<<"impossible"<<endl;
        }
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值