大数字相加

唉 由于好长时间不写代码了 做了半个小时才想明白,以此激励吧。

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
额 就是关于上述题

代码:


#include<stdio.h>
#include<string.h>
int main()
{
int T;
scanf("%d",&T);
char a[1002],b[1002];
int al,bl,i,num;
for(num=1;num<=T;num++)
{
scanf("%s %s",a,b);
al = strlen(a);
bl = strlen(b);


a[al]='\0';
b[bl]='\0';


int an[1002],bn[1002];//用于存放数字;
memset(an,0,1002*sizeof(int));
    memset(bn,0,1002*sizeof(int));
for(i=0;i<al;i++)
{
an[i]=a[al-1-i]-'0';//an[0]存个位数
}
for(i=0;i<bl;i++)
{
bn[i]=b[bl-1-i]-'0';
}

int sum[1002],max,j;
memset(sum,0,1002*sizeof(int));
if(al>bl)
max=al;
else
max=bl;
for(i=0;i<=max+1;i++)
{
int s=sum[i];
sum[i]=(s+an[i]+bn[i])%10;
sum[i+1]=(s+an[i]+bn[i])/10;
}
//判断前面零舍去;
for(i=max+1;i>=0;i--)
{
  if(sum[i]==0)
  continue;
  else
  break;
}
printf("Case %d:\n",num);
printf("%s + %s = ",a,b);
for(j=i;j>=0;j--)
{
printf("%d",sum[j]);
}
printf("\n");
if(num!=T)
printf("\n");
}
return 0;
}


关于if(num!=T)要换行,这算是一个小问题吧。

额 好啦 就针对这个讲讲怎么想到的吧

首先,通过字符串获取两个数字,然后求他们的长度al,bl;

然后呢根据他们转化成数组,因为数组好运算,毕竟这不是数字嘛。

最后就是计算啦,max求的最大的长度,max+1是为了防止加完了最高位进一,而求sum中定义了一个s是因为上一位的时候,可能有进一使sum[i]=1;但是为什么不用sum[i]而用s呢? 那是因为那求本位的时候就会把这个一给改变数值,所以没办法啊 ,只好再设一个变量了,是不是很不好啊。额 针对这个别人也给出了一种方法:


for(i=0;i<1002;i++)
{
s1[i]+=s2[i];
if(s1[i]>=10)
{
s1[i]-=10;
s1[i+1]++;
}


因为考虑到加法只会进一,所以这样写倒也挺好,还方便。

编程最主要的还是要心细,要考虑周到。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值