zookeeper-3.5.5安装报错:找不到或无法加载主类 org.apache.zookeeper.server.quorum.QuorumPeerMain-新版本zookeeper易犯错误

安装报错

Zookeeper已经安装了很多次了,但是今天竟然遇到了问题。

1、首先去官网下载了最新版本:zookeeper-3.5.5
2、回到我的Centos服务器上,修改配置文件。
3、然后启动,竟然报错了:

错误: 找不到或无法加载主类org.apache.zookeeper.server.quorum.QuorumPeerMain

排查之路

崩溃,天呀,见鬼了,于是进入到了我的排查之路,各种百度,各种办法都无法解决我的问题。
于是静下心来,排查问题,先看我们的下载页面,有两个包,啥区别呢?

在这里插入图片描述

接下来,在版本的更新记录中终于找到了答案:

在这里插入图片描述

解决方案

总结:原来从目前的最新版本3.5.5开始,带有bin名称的包才是我们想要的下载可以直接使用的里面有编译后的二进制的包,而之前的普通的tar.gz的包里面是只是源码的包无法直接使用。

好想吐槽下啊,Zookeeper的包的变动,源码的包就不能向其他的安装包一样加个src的标识吗?见名知意多好,以避免误下载。

所以同学们,如果下载3.5.5以后的版本的Zookeeper安装包,我们乖乖的下载带有bin标识的包就不会有问题了。

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页