【差分约束系统】Intervals POJ1201

Intervals

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18719 Accepted: 7029

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6



题目大意

有n个区间,每个区间有3个值,ai,bi,ci代表,在区间[ai,bi]上至少要选择ci个整数点,ci可以在区间内任意取不重复的点
现在要满足所有区间的自身条件,问最少选多少个点



根据题目读入a,b,c可以得知  dis[b] - dis[a-1] >= c 【类似前缀和,一定要是 a - 1 】

我们直接a=a-1,然后得到b-a>=c,再推出 a-b<=-c,即求最长路【看样子题目保证有解,所以堆优dijkstra也行】

然后还有一个隐含条件,0<=dis[i+1]-dis[i]<=1


测评情况(POJ)




C++ AC Code

/*http://blog.csdn.net/jiangzh7
By Jiangzh*/
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N=50000+10;
const int inf=0x3f3f3f3f;

int s=inf,t=0;
struct link{int y,z;link *next;}*head[N];
int dist[N],inQ[N];
queue<int> Q;

void inlink(int x,int y,int z)
{
	link *tmp=new link;
	tmp->y=y;tmp->z=z;
	tmp->next=head[x];
	head[x]=tmp;
}

void spfa()
{
	for(int i=s;i<=t;i++) dist[i]=-inf;
	dist[s]=0;Q.push(s);
	while(!Q.empty())
	{
		int x=Q.front();
		Q.pop();inQ[x]=0;
		for(link *node=head[x];node;node=node->next)
			if(dist[node->y]<dist[x]+node->z)
			{
				dist[node->y]=dist[x]+node->z;
				if(!inQ[node->y])
				{
					inQ[node->y]=1;
					Q.push(node->y);
				}
			}
	}
}

int main()
{
	freopen("interval.in","r",stdin);
	freopen("interval.out","w",stdout);
	int m;scanf("%d",&m);
	while(m--)
	{
		int a,b,c;//b-a>=c
		scanf("%d%d%d",&a,&b,&c);a--;
		s=min(s,a);t=max(t,b);
		inlink(a,b,c);//a-b<=-c
	}
	for(int i=s;i<t;i++)
	{
		inlink(i,i+1,0);
		inlink(i+1,i,-1);
	}
	spfa();
	printf("%d\n",dist[t]-dist[s]);
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值