hdu1546—Idiomatic Phrases Game(spfa)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1546

Idiomatic Phrases Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3631    Accepted Submission(s): 1229


Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary. 
 

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case. 
 

Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
 

Sample Input
  
  
5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0
 

Sample Output
  
  
17 -1

题目大意:给你一些成语,a成语的后4个字符等于b成语的前4个字符,则能从a走到b,浏览每个成语有个时间t,从第一个成语到最后一个成语所需的最小时间(题目读了好久才懂,太菜了)

解题思路:spfa

第一个成语的后四个字符作为起点s,最后一个成语的前四个字符作为终点e,跑个spfa,求Lse的最短距离,记得加上第一个成语的时间t。(之前用第一个成语的前4个字符作为起点,结果wa了,可能终点就是起点,这样结果就是0,显然是不对的)


#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <iostream>  
#include <queue>
#include <set>
#include <string>
#include <stack>
#include <algorithm>
#include <map>
using namespace std;  
typedef long long ull;
const int N = 2008;
const int M = 108;
const int INF = 0x3fffffff;
const double Pi = acos(-1.0);

struct Edge{
	int node,len;
	Edge*next;
}m_edge[N];
Edge*head[N];
int dist[N],vis[N],Ecnt;

void init()
{
	Ecnt = 0;
	fill( head , head+N , (Edge*)0 );
}

void mkEdge( int a , int b , int c )
{
	m_edge[Ecnt].node = b;
	m_edge[Ecnt].len = c;
	m_edge[Ecnt].next = head[a];
	head[a] = m_edge+Ecnt++;
}

void spfa()
{
	fill( dist , dist+N , INF );
	fill( vis , vis+N , 0 );
	queue<int>point;
	point.push(1);
	vis[1] = 1;
	dist[1] = 0;
	while( !point.empty() ){
		int s = point.front();
		point.pop();
		vis[s] = 0;
		for( Edge*p = head[s] ; p ; p = p->next ){
			int t = p->node;
			if( dist[t] > dist[s]+p->len ){
				dist[t] = dist[s]+p->len;
				if( !vis[t] ){
					point.push(t);
					vis[t] = 1;
				}
			}
		}
	}
}

int main()
{
	int n;
	while( ~scanf("%d",&n) ){
		init();
		if( n == 0 ) break;
		string str,a,b,e;
		int w,cnt = 2;
		map<string,int>mp;
		cin >> w >> str;
		a.assign(str,str.length()-4,4);
		mp[a] = 1;
		int ans = w;
		for( int i = 0 ; i < n-2 ; ++i ){
			cin >> w >> str;
			a.assign(str,0,4);
			b.assign(str,str.length()-4,4);
			if( !mp[a] ) mp[a] = cnt++;
			if( !mp[b] ) mp[b] = cnt++;
			mkEdge( mp[a] , mp[b] , w );
		}
		cin >> w >> str;
		e.assign(str,0,4);
		if( !mp[e] ) mp[e] = cnt++; 
		int s = mp[e];
		spfa();
		if( dist[s] == INF ) printf("%d\n",-1);
		else printf("%d\n",ans+dist[s]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值