poj1655—Balancing Act(树的重心)

题目链接:传送门

Balancing Act
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14208 Accepted: 6008

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2


解题思路:求树的重心


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

const int N = 20090;
const int M = 100000;

//树的重心:删掉这个节点后将树分成几个部分,使得这几个部分中点个数的最大值最小
//以每个点作为根节点搜一次,求得改点的子树中点数的最大值,然后求其中的最小值
//但是复杂度为0(n^2)肯定TLE
//其实只要以某个节点u为根搜一次就可以了。
//当向下搜到某个节点v时,我们可以求出节点v的子树中最大的节点数
//这时只要再和节点v的非子树节点数比较就行了,假如节点v的子树节点数为m,节点数为n
//显然节点v的非子树节点数为n-m-1,这样就相当于求出了去掉v后,子树中节点数最大的值

struct Edge{
    int node;
    Edge*next;
}m_edge[N*2];
Edge*head[N];
int Ecnt,vis[N],son[N];
int Num,Size; //树的重心的编号,划分后的最大值

void init()
{
    Ecnt = 0; Num = 0; Size = INT_MAX;
    fill( head , head+N , (Edge*)0 );
    fill( vis , vis+N , 0 );
}

void mkEdge( int a , int b )
{
    m_edge[Ecnt].node = b;
    m_edge[Ecnt].next = head[a];
    head[a] = m_edge+Ecnt++;
}

int n;  //节点个数
void dfs( int u )
{
    vis[u] = 1;
    son[u] = 0;
    int temp = 0;

    for( Edge*p = head[u] ; p ; p = p->next ){
        int v = p->node;
        if( !vis[v] ){
            dfs(v);
            //子树中节点数的最大值
            temp = max(temp,son[v]+1);
            //节点u的子树树
            son[u] += son[v]+1;
        }
    }
    //与非子树节点数比较
    temp = max(temp,n-son[u]-1);

    if( temp < Size || temp == Size&&u < Num ){
        Size = temp;
        Num = u;
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while( T-- ){
        init();
        int a,b;
        scanf("%d",&n);
        for( int i = 0 ; i < n-1 ; ++i ){
            scanf("%d%d",&a,&b);
            mkEdge(a,b);
            mkEdge(b,a);
        }
        dfs(1);
        printf("%d %d\n",Num,Size);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值