hdu6215—Brute Force Sorting(双向链表)

题目链接:传送门

Brute Force Sorting

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1849    Accepted Submission(s): 459


Problem Description
Beerus needs to sort an array of  N  integers. Algorithms are not Beerus's strength. Destruction is what he excels. He can destroy all unsorted numbers in the array simultaneously. A number  A[i]  of the array is sorted if it satisfies the following requirements.
1.  A[i]  is the first element of the array, or it is no smaller than the left one  A[i1] .
2.  A[i]  is the last element of the array, or it is no bigger than the right one  A[i+1] .
In  [1,4,5,2,3] , for instance, the element  5  and the element  2  would be destoryed by Beerus. The array would become  [1,4,3] . If the new array were still unsorted, Beerus would do it again.
Help Beerus predict the final array.
 

Input
The first line of input contains an integer  T (1T10)  which is the total number of test cases.
For each test case, the first line provides the size of the inital array which would be positive and no bigger than  100000 .
The second line describes the array with  N  positive integers  A[1],A[2],,A[N]  where each integer  A[i]  satisfies  1A[i]100000 .
 

Output
For eact test case output two lines.
The first line contains an integer  M  which is the size of the final array.
The second line contains  M  integers describing the final array.
If the final array is empty,  M  should be  0  and the second line should be an empty line.
 

Sample Input
  
  
5 5 1 2 3 4 5 5 5 4 3 2 1 5 1 2 3 2 1 5 1 3 5 4 2 5 2 4 1 3 5
 

Sample Output
  
  
5 1 2 3 4 5 0 2 1 2 2 1 3 3 2 3 5
 

Source


解题思路:每删除一个数只会对这个数的前面那个数和后面那个数产生影响,用一个set将这些数保存起来(去重),再次对序列进行操作时,不需要再将整个序列扫描一遍,此时只需要对set里面的数进行判断是否合乎条件,这里用双向链表来实现。最多删除n个数,用set来保存被影响的数,时间复杂度尾nlogn。(链表都差点忘记写了大哭

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>

using namespace std;

typedef long long ll;

const int INF = 0x3fffffff;
const int N = 100100;

struct Node{
    int pos,id;
    Node*pre,*next;
}node[N];

vector<int>vec;
set<int>st;
int tick[N];

void Delete(int u)
{
    Node*p = node[u].pre;
    p->next = node[u].next;
    node[u].next->pre = p;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(tick,0,sizeof(tick));
        memset(node,0,sizeof(node));
        vec.clear();
        st.clear();

        int n,p;
        scanf("%d",&n);

        node[0].pos = 0;
        node[0].id = 0;
        node[0].next = &node[1];
        node[0].pre = NULL;

        for( int i = 1 ; i <= n ; ++i ){
            scanf("%d",&node[i].pos);
            node[i].id = i;
            node[i].next = &node[i+1];
            node[i].pre  = &node[i-1];
        }

        node[n+1].pos = INF;
        node[n+1].id = n+1;
        node[n+1].pre = &node[n];
        node[n+1].next = NULL;

        tick[0] = tick[n+1] = 1;

        for( int i = 1 ; i <= n ; ++i ){
            if(node[i].pos < node[i-1].pos || node[i].pos > node[i+1].pos){
                vec.push_back(i);
                tick[i] = 1;
            }
        }

        int flag = 1;
        while(flag){
            st.clear();
            for( int i = 0 ; i < vec.size() ; ++i ){
                int id1 = node[vec[i]].pre->id;
                int id2 = node[vec[i]].next->id;
                if(!tick[id1]) st.insert(id1);
                if(!tick[id2]) st.insert(id2);
                Delete(vec[i]);
            }

            vec.clear();
            for(set<int>::iterator it = st.begin() ; it != st.end() ; ++it){
                int p = *it;
                if(node[p].pos < node[p].pre->pos || node[p].pos > node[p].next->pos){
                    tick[p] = 1;
                    vec.push_back(p);
                }
            }

            if(vec.size() == 0) flag = 0;
        }

        for( int i = 1 ; i <= n ; ++i ){
            if(tick[i] == 0) vec.push_back(node[i].pos);
        }

        if(vec.size() == 0){
            printf("0\n\n");
        }else{
            printf("%d\n",vec.size());
            for( int i = 0 ; i < vec.size() ; ++i ){
                printf("%d ",vec[i]);
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值