poj3461—Oulipo(查找子串在目标串中出现次数)

题目链接:传送门

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44522 Accepted: 17847

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0


直接上代码吧

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 1005000;
const int M = 10100;

//poj3461
//计算子串在目标串中出现的次数

int nt[N],pLen;
char s[N],p[M];

void GetNext(char* p)
{
    int pLen = strlen(p);
    nt[0] = -1;
    int k = -1,j = 0;
    while (j < pLen - 1){
        //p[k]表示前缀,p[j]表示后缀
        if (k == -1 || p[j] == p[k]){
            ++k;
            ++j;
            if (p[j] != p[k])
                nt[j] = k;   //之前只有这一行
            else
                //因为不能出现p[j] = p[ nt[j ]]
                //所以当出现时需要继续递归,k = nt[k] = nt[nt[k]]
                nt[j] = nt[k];
        }else{
            k = nt[k];
        }
    }
}

int KMP(char* s, char* p)
{
    int i = 0,j = 0,ans = 0;
    int sLen = strlen(s);
    while (i < sLen){
	//找到一处匹配
        if(j == pLen){
            ans++;
            j = nt[pLen];
        }
        //如果j = -1,或者当前字符匹配成功(即S[i] == P[j]),都令i++,j++
        if (j == -1 || s[i] == p[j]){
            i++;
            j++;
        }else{
            //如果j != -1,且当前字符匹配失败(即S[i] != P[j]),则令 i 不变,j = nt[j]
            //nt[j]即为j所对应的nt值
            j = nt[j];
        }
    }
    if(j == pLen){
        ans++;
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf(" %s",p);
        scanf( "%s",s);
        pLen = strlen(p);
        p[pLen] = '#';
        GetNext(p);

        printf("%d\n",KMP(s,p));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值