poj2104——K-th Number(划分树)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 30986 Accepted: 9501
Case Time Limit: 2000MS
Description
You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output

5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
Source

Northeastern Europe 2004, Northern Subregion

解析:

         求区间第K大,很裸的的划分树。。。

         对于我这样马虎的人,一个很小的错找了很久。。。

代码:

         

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 100005
int n,m;
int val[20][N],sum[20][N],num[20][N];
int order[N],lsum=0;

void build(int h,int l,int r)
{
    if(l==r)return ;
    int mid=(l+r)>>1;
    int same=mid-l+1;
    for(int i=l;i<=r;i++)
        if(val[h][i]<order[mid])same--;
    int cl=l,cr=mid+1;
    for(int i=l;i<=r;i++)
    {
        int flag=0;
        if((val[h][i]<order[mid])||(val[h][i]==order[mid]&&same))
        {
            flag=1;
            val[h+1][cl++]=val[h][i];      //进左子树
            //sum[h][i]+=val[h][i];
            if(val[h][i]==order[mid])same--;
        }
        else
        {
            //sum[h][i]+=val[h][i];
            val[h+1][cr++]=val[h][i];           //进右子树
        }
        num[h][i]=num[h][i-1]+flag;         //num维护进左子树的个数
    }
    build(h+1,l,mid);
    build(h+1,mid+1,r);
}

int query(int h,int ll,int rr,int l,int r,int k)
{
    if(ll==rr)return val[h][ll];
    //cout<<l<<' '<<r<<endl;
    int mid=(ll+rr)>>1;
    //cout<<mid<<endl;
    int lx=num[h][l-1]-num[h][ll-1];        //lx:区间ll-(l-1)进左子树的个数
    int ly=num[h][r]-num[h][l-1];           //ly:区间l-r进左子树的个数
    int rx=l-1-ll+1-lx;                     //与上对应(进右子树的个数)
    int ry=r-l+1-ly;                        //
    if(k<=ly)return query(h+1,ll,mid,ll+lx,ll+lx+ly-1,k);//在左子树找第K大
    else
    {
        //lsum+=sum[h][r]-sum[h][l-1];
        //l=mid+1+rx;r=mid+1+rx+ry-1;
        return query(h+1,mid+1,rr,mid+1+rx,mid+1+rx+ry-1,k-ly); //在右子树找第k-ly大
    }
}

void read()
{
    freopen("poj2104.in","r",stdin);
    freopen("poj2104.out","w",stdout);
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&val[0][i]);
        order[i]=val[0][i];
        //sum[i]=sum[i-1]+order[i];
    }
}

void work()
{
    sort(order+1,order+n+1);
    //for(int i=1;i<=n;i++)printf("%d ",order[i]);
    build(0,1,n);
    for(int i=1;i<=m;i++)
    {
        int l,r,k;
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",query(0,1,n,l,r,k));
    }
}

int main()
{
    read();
    work();
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值