poj3468——A Simple Problem with Integers(线段树)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 41631 Accepted: 12100
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly--2007.11.25, Yang Yi

解析:

         懒标记入门题。。。

         注意sum会爆int

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=110010;

long long sum[maxn*4];
long long lazy[maxn*4];
int n,q,a[maxn];

void up(int p)
{
    sum[p]=sum[p<<1]+sum[(p<<1)+1];
}

void down(int p,int len)
{
    if(lazy[p])
    {
        lazy[p<<1]+=lazy[p];
        lazy[(p<<1)+1]+=lazy[p];
        sum[p<<1]+=lazy[p]*(len-(len>>1));
        sum[(p<<1)+1]+=lazy[p]*(len>>1);
        lazy[p]=0;
    }
}

void build(int p,int l,int r)
{
    lazy[p]=0;
    if(l==r)
    {
        sum[p]=a[l];
        return;
    }
    int m=(l+r)>>1;
    build(p<<1,l,m);
    build((p<<1)+1,m+1,r);
    up(p);
}

long long query(int p,int ll,int rr,int l,int r)
{
    if(l<=ll && r>=rr)
        return sum[p];
    down(p,rr-ll+1);
    int m=(ll+rr)>>1;
    long long ret=0;
    if(l<=m) ret+=query(p<<1,ll,m,l,r);
    if(r>m) ret+=query((p<<1)+1,m+1,rr,l,r);
    return ret;
}

void update(int p,int ll,int rr,int l,int r,int deta)
{
    if(l<=ll && r>=rr)
    {
        lazy[p]+=deta;
        sum[p]+=(long long)deta*(rr-ll+1);
        return ;
    }
    down(p,rr-ll+1);
    int m=(ll+rr)>>1;
    if(l<=m)update(p<<1,ll,m,l,r,deta);
    if(r>m)update((p<<1)+1,m+1,rr,l,r,deta);
    up(p);
}

void read()
{
    freopen("poj3468.in","r",stdin);
    freopen("poj3468.out","w",stdout);
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
    scanf("%d",&a[i]);
    build(1,1,n);
    for(int i=1;i<=q;i++)
    {
        char op[3];
        scanf("%s",op);
        if(op[0]=='Q')
        {
            int a,b;
            scanf("%d%d",&a,&b);
            printf("%I64d\n",query(1,1,n,a,b));
        }
        else
        {
            int a,b,l;
            scanf("%d%d%d",&a,&b,&l);
            update(1,1,n,a,b,l);
        }
    }
}

int main()
{
    read();
    //work();
    return 0;
}

代码:


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值