hdu3530——Subsequence(单调队列优化DP)

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3213    Accepted Submission(s): 1044

Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 
Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 
Output
For each test case, print the length of the subsequence on a single line.
 
Sample Input
5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5
 
Sample Output
5
4
 
Source
2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU
 

Recommend

zhengfeng

解析:

         dp[i]表示以第i个数字为结尾的满足条件的最长长度。。。

         用两个单调队列分别维护递增和递减序列。。。

         考虑dp[i-1],当a[i]加入时如果max-min>k,就在单调队列中让队首指针向前移,让大的小一点,小的大一点。。。 

         直到找到满足条件的位置。。。且要记录下最小的起始位置,使序列长度更长。。。

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,k,up[100005],down[100005],a[100005],now;

int main()
{
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
	    for(int i=1;i<=n;i++)scanf("%d",&a[i]);
	    int ans=0;down[0]=up[0]=0;  now=0;
	    int up_st=0,down_st=0,up_ed=0,down_ed=0;
	    for(int i=1;i<=n;i++)
	    {
            while(up_st<up_ed && a[up[up_ed-1]]>a[i])up_ed--;//维护单调递增
		    while(down_st<down_ed && a[down[down_ed-1]]<a[i])down_ed--;//维护单调递减
		    up[up_ed++]=i;down[down_ed++]=i;
		    while(a[down[down_st]]-a[up[up_st]]>k)
			    now=(up[up_st]<down[down_st]?up[up_st++]:down[down_st++]);
		    if(a[down[down_st]]-a[up[up_st]]>=m)ans=max(ans,i-now);
        }
        printf("%d\n",ans);
	}
	return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值