第一天:计算字符串最后一个单词的长度,单词以空格隔开。

描述 :计算字符串最后一个单词的长度,单词以空格隔开。
知识点: 字符串,循环
输入 :一行字符串,长度小于128。
输出 :整数N,最后一个单词的长度。
样例输入 hello world
样例输出 5
1.while循环

#include<iostream>  
#include<string>  
using namespace std; 
void main(void)
{
    char str[128];  
    gets(str);  
    int count=0;  
    int len=strlen(str);
while(str[--len]!=' '&&len>-1) count++; 
    cout<<count<<endl;  
    system("pause");  
}

2.for 循环

#include "stdafx.h"
#include<iostream>  
#include<string>  
using namespace std; 
void main(void)
{
    cout<<"Please Input a string:";
    char str[128];  
    gets(str);  
    int count=0;  
    int len=strlen(str);
    for (int i=len-1;i>=0;i--)
    {
        if(str[i]!=' ')
          count++;
          else
          break;
    }

    cout<<"The length of last word is:";
    cout<<count<<endl;  
    system("pause");  
}

3.测试结果

测试输入:hellow world
测试:输入hello

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值