UVA 442 Matrix Chain Multiplication (矩阵链乘)

该博客讨论了如何高效地解决UVA 442 Matrix Chain Multiplication问题,即矩阵链乘。矩阵乘法虽然结合律使得顺序不固定,但不同的乘法顺序会导致不同的运算次数。例如,对于矩阵A(50*10)、B(10*20)和C(20*5),计算(A*B)*C和A*(B*C)所需的乘法次数分别为15000和3500。文章旨在找到最优策略,最小化所需的基本乘法数量。输入包括矩阵列表和表达式,输出是每个表达式的正确性及所需乘法次数。
摘要由CSDN通过智能技术生成


https://vjudge.net/problem/UVA-442

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n  (  tex2html_wrap_inline28  ), representing the number of matrices in the first part. The next  n  lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word " error " if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125
思路:类似于加减法。用堆栈模拟计算
import java.util.Scanner;
import java.util.Stack;

public class Main {

	public static void main(String[] args) {
		Scanner scan = new Scanner(System.in);
		int N = scan.nextInt();
		Matrix[] m = new Matrix[26];
		for(int i=0;i<N;i++){
			char c = scan.next().charAt(0);
			int a = scan.nextInt();
			int b = scan.nextInt();
			m[c-'A'] = new Matrix(a, b);
		}
		while(scan.hasNext()){
			String str = scan.next();
			Stack<Matrix> stack = new Stack<Matrix>();
			boolean error = false;
			int ans = 0;
			for(int i=0;i<str.length();i++){
				char c = str.charAt(i);
				if(c>='A'&&c<='Z'){
					stack.push(m[c-'A']);
				}else if(c==')'){
					Matrix m2 = stack.pop();
					Matrix m1 = stack.pop();
					if(m1.b!=m2.a){
						error = true;
						break;
					}else{
						ans += m1.a*m1.b*m2.b;
						stack.push(new Matrix(m1.a,m2.b));
					}
				}
			}
			System.out.println(error?"error":ans);
		}
	}
	
	static class Matrix{
		int a;
		int b;
		public Matrix(int a,int b){
			this.a = a;
			this.b = b;
		}
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值