poj 1979 Red and Black (简单BFS)

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 28318 Accepted: 15405

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

这题只需要使用简单的BFS进行搜索即可

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <ctype.h>
#include <algorithm>
#include <map>
#include <math.h>
#include <stack>
#include <queue>
#define Max 25
#define inf 100000000
using namespace std;
char m[Max][Max];
int Mov[4][2] = {{0,1},{1,0},{-1,0},{0,-1}};
bool vis[Max][Max];
int W,H;
int dfs(int x,int y){
    int res = 1;
    vis[x][y] = true;
    for (int i=0; i<4; i++) {
        int nx = x+Mov[i][0],ny = y + Mov[i][1];
        if (nx>=0&&nx<H&&ny>=0&&ny<W) {
            if (!vis[nx][ny]&&m[nx][ny] != '#') {
                res += dfs(nx, ny);
            }
        }
    }
   // printf("%d\n",res);
    return res;    //统计个数
}
int main(){
    while (scanf("%d%d",&W,&H)!=EOF&&W+H) {
        memset(vis, 0, sizeof(vis));
        //getchar();
        int xx = -1,yy = -1;
        for (int i=0; i<H; i++) {
            scanf("%s",m[i]);
            for (int j=0; j<W; j++) {
                if (m[i][j] == '@') {
                    xx = i,yy = j;
                }
            }
        }
//        for (int i=0; i<H; i++) {
//            printf("%s\n",m[i]);
//        }
        printf("%d\n",dfs(xx, yy));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值