poj 3190 Stall Reservations(贪心)

Stall Reservations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4636 Accepted: 1660 Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

分析:这题是一道区间贪心问题
先把数据按照左区间的大小,小到大排序

第一次做超时^(-_-)!因为我没有想到用优先队列处理,所以就用了O(n^2)的做法做,使用used来标记是否访问过,也就是一层层的堆牛
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <ctype.h>
#include <algorithm>
#include <map>
#include <math.h>
#include <stack>
#include <queue>
#include <set>
#define Max 50100
#define inf 100000000
using namespace std;
struct Node{
    int left,right,nos;
    int no;
}a[Max];
int used[Max];
bool cmp(Node a,Node b){
    if (a.left<b.left) {
        return true;
    }else if(a.left == b.left){
        if (a.right<b.right) {
            return true;
        }
        return false;
    }
    return false;
}
int cmp1(Node a,Node b){
    return a.no<b.no;
}
int main(){
    int n;
    while (scanf("%d",&n)!=EOF) {
        memset(used, 0, sizeof(used));
        for (int i=0; i<n; i++) {
            scanf("%d%d",&a[i].left,&a[i].right);
            a[i].no = i;
        }
        sort(a, a+n, cmp);
        int ans = 1;
        for (int i=0; i<n; i++) {
            if (!used[i]) {
                int tmp = a[i].right;
                a[i].nos = ans;
                for (int j=i; j<n; j++) {
                    if (!used[j]&&a[j].left>tmp) {
                        tmp = a[j].right;
                        used[j] = true;
                        a[j].nos = ans;
                    }
                }
                ans++;
            }
        }
        sort(a, a+n, cmp1);
        printf("%d\n",ans-1);
        for (int i=0; i<n; i++) {
            printf("%d\n",a[i].nos);
        }
    }
    return 0;
}

AC代码:
使用优先队列存储牛栏的个数以及最右边的值(end/cow.right)
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <ctype.h>
#include <algorithm>
#include <map>
#include <math.h>
#include <stack>
#include <queue>
#include <set>
#define Max 50100
#define inf 100000000
using namespace std;
struct Node{
    int left,right,nos;
    int no;
}a[Max];
int result[Max];
struct shelter{
    int end;
    int id;
    friend bool operator<(shelter a,shelter b){
        return a.end>b.end;
    }
    shelter(int _end,int _id):end(_end),id(_id){}
    shelter() {}
};
int cmp(Node a,Node b){
    return a.left<b.left;
}
int main()
{
    int n;
    while (scanf("%d",&n)!=EOF) {
        for (int i=0; i<n; i++) {
            scanf("%d%d",&a[i].left,&a[i].right);
            a[i].no = i;
        }
        sort(a, a+n, cmp);
        priority_queue<shelter>que;
        que.push(shelter(0,1));
        for (int i=0; i<n; i++) {
            shelter e;
            if (a[i].left<=que.top().end) {
                e.id = (int)que.size()+1;
            }else{
                e.id = que.top().id;
                que.pop();
            }
            e.end = a[i].right;
            result[a[i].no] = e.id;
            que.push(e);
        }
        printf("%lu\n",que.size());
        for (int i=0; i<n; i++) {
            printf("%d\n",result[i]);
        }
    }
    return 0;
}

总结:下次做贪心问题,我不能再用O(n^2)的算法惹!!!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值