POJ 2367 Genealogical tree (拓扑排序)

Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4341 Accepted: 2886 Special Judge
Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output

2 4 5 3 1


题解:

输入N   m

5   ————N

0       i=1,与m的关系,m为0时表示没有关系           

4 5 1 0  i=2

1 0

5 3 0

3 0

最终输出关系顺序(拓扑排序)

简单的拓扑排序输出顺序即可

一个标准的拓扑排序题解。
要点:
1 查找没有父亲节点的点,先输出这些点
2 使用一个数组,del[i]记录已经输出的点将与之相连的点的入度均减一
3 输出了的点不再计算在父亲节点中,循环第1步,直到输出所有点

代码:

#include<cstdio>
#include<cstring>
#include<queue>
#define N 110
using namespace std;
int n;
int relate[N][N];
int indegree[N];///记录入度
int res[N];
///拓扑排序的核心
void topo_sort()
{

    int i,j;
    int flag=1;
    for(j=1;j<=n;++j)
    {
        int temp=-1;
        for(i=1;i<=n;++i)
        {
            if(indegree[i]==0)
            {
                temp=i;
                break;
            }
        }
        indegree[temp]=-1;
        flag?printf("%d",temp):printf(" %d",temp);
        flag=0;
        for(i=1;i<=n;++i)
        {
            if(relate[temp][i])
            {
                indegree[i]--;
            }
        }
    }
  printf("\n");
}

int main()
{
    int tmp,m;
    int i,j;
    while(~scanf("%d",&n))
    {
        memset(indegree,0,sizeof(indegree));
        memset(relate,0,sizeof(relate));
        for(i=1;i<=n;++i)
        {
            while(~scanf("%d",&m),m)
            {
                relate[i][m]=1;
                indegree[m]++;
            }

        }
        topo_sort();
    }
    return 0;
}

代码2:

邻接表形式:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

struct note
{
    int to;
    int next ;
};

note edge[10004];

int head[10005],ip,iq,indegree[10005],que[10005];
///邻接表的建立
void add(int u,int v)
{
    edge[ip].to=v;
    edge[ip].next=head[u];
    head[u]=ip++;
}
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        memset(head,-1,sizeof(head));
        memset(que,0,sizeof(que));
        memset(indegree,0,sizeof(indegree));
        ip=iq=0;
        for(int i=1; i<=n; i++)
        {
            while(1)
            {
                scanf("%d",&m);
                if(m==0)
                    break;
                add(i,m);///邻接表
                indegree[m]++;
            }
        }
        for(int i=1; i<=n; i++)
        {
            if(indegree[i]==0)
                que[iq++]=i;
        }
        for(int i=0; i<iq; i++)
        {
            for(int k=head[que[i]]; k!=-1; k=edge[k].next)
            {
                if(--indegree[edge[k].to]==0)
                    que[iq++]=edge[k].to;
            }
        }
        for(int i=0; i<n; i++)
            printf(i==n-1?"%d\n":"%d ",que[i]);
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值