HDOJ 1002 A + B Problem II(大数)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 260025    Accepted Submission(s): 50264


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1004  1003  1008  1005  1089
思路:用数组处理大数问题,用p表示进位
注意格式:Case %d:\n      %s + %s = (空格问题)

#include<stdio.h>
#include<string.h>
int main(){
	int n,alen,blen,i,j=1,k,p=0;
	char a[1000],b[1000],c[1001];
	scanf("%d",&n);
	while(n){//不能是n--
		scanf("%s %s",a,b);
		printf("Case %d:\n",j);
		printf("%s + %s = ",a,b);
		alen=strlen(a)-1;
		blen=strlen(b)-1;
		for(k=0;alen>=0||blen>=0;alen--,blen--,k++){
			if(alen>=0&&blen>=0) c[k]=a[alen]+b[blen]-'0'+p;
			if(alen<0&&blen>=0) c[k]=b[blen]+p;
			if(alen>=0&&blen<0) c[k]=a[alen]+p;
			p=0;          //进位加上之后要清零
			if(c[k]>'9') { c[k]-=10;  p=1; }
		}
		if(p==1) printf("1");//最后的进位p=1
                while(k--) 
			printf("%c",c[k]);
		j++;        
		if(n!=1) printf("\n\n");
		else printf("\n");
		n--;//此处n--
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值