HDOJ 1702 ACboy needs your help again!(栈和队列)

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4462    Accepted Submission(s): 2281


Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
  
  
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
  
  
1 2 2 1 1 2 None 2 3
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1701  1700  1704  1706  1705

思路:根据队列的先进先出特性,和栈的后进先出特性 处理此类问题。
要用队列的话,没有q.top(),要用q.front(),q.top()是优先队列里的。
队列部分基本和栈部分一样。代码看着长,实际上写栈时只用copy队列再稍微改一改就行了。

#include<cstdio>
#include<cstring>
#include<stack> //栈的头文件
#include<queue>//队列的头文件
using namespace std;
int main(){
    int n,m,i,j,num;
    char a[200][200],str[200]; //a为输入的字符数组,str为FIFO/FILO
    scanf("%d",&n);
    while(n--){
        scanf("%d%s",&m,str); //str输入是"FIFO"或者输入是"FILO"
        memset(a,0,sizeof(a)); //如果不初始化,各种数据过,各种WA
        for(i=0;i<=m;i++){
            gets(a[i]); //输入IN,OUT什么的
        }
        /******************队列部分***********************/
        if(strcmp(str,"FIFO")==0){ //先进先出FIFO情况,用队列que
              queue <int> que; //如果不初始化,各种数据过,各种WA
            for(i=1;i<=m;i++){
                num=a[i][3]-'0'; //num初始为第一个数
                if(a[i][0]=='I'){ //输入IN,进队列
                    for(j=4;j<strlen(a[i]);j++) num=num*10+a[i][j]-'0'; //记录IN 后的数,字符型转为整型
                    que.push(num); //数字进队列
                }
                else{ //输入OUT,从头出队列
                    if(!que.empty()){ //若队列不空
                        printf("%d\n",que.front()); //输出队列的头元素
                        que.pop(); //消除队列头
                    }
                    else printf("None\n");//若队列空,不能出队列
                }
            }
        }//if FIFO
        /*********************栈部分***********************/
        else{//先进后出FILO情况,用栈sta
            stack <int> sta;//如果不初始化,各种数据过,各种WA
            for(i=1;i<=m;i++){
                num=a[i][3]-'0';//num初始为第一个数
                if(a[i][0]=='I'){//输入IN,进栈
                    for(j=4;j<strlen(a[i]);j++) num=num*10+a[i][j]-'0';//记录IN 后的数,字符型转为整型
                    sta.push(num);//数字进栈
                }
                else{//输入OUT,从尾出栈
                    if(!sta.empty()){//若栈不空
                        printf("%d\n",sta.top());//输出栈的尾元素
                        sta.pop();//消除栈尾
                    }
                    else printf("None\n");//若栈空,不能出栈
                }
            }
        }//else FILO
    }
    return 0;
}


转载请注明出处: http://blog.csdn.net/jinjide_ajin/article/details/47166421

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值