1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19913    Accepted Submission(s): 8535


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1

题目大意:求b在a中第一次出现开始位置的下标(从1开始)

思路:kmp模板题,不过要注意b中可以出现负数,所有还是要改一点点的,因为kmp模板解决的是字符串问题,这里把字符串改成数组就OK了

<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<map>
#define LL long long
using namespace std;
const int maxn = 10000+5;
int Next[maxn],a[maxn*100],b[maxn],na,nb;
void getNext()
{
    Next[0]=-1;
    Next[1]=0;
    for(int i=2;i<nb;i++){
        if(b[i-1]==b[Next[i-1]]) Next[i]=Next[i-1]+1;
        else{
            int t=Next[i-1];
            while(b[i-1]!=b[t]){
                t=Next[t];
                if(t==-1) break;
            }
            Next[i]=t+1;
        }
    }
}
int kmp()
{
    getNext();
    int i=0,j=0;
    while(i<na && j<nb){
        if(j==-1 || a[i]==b[j]) i++,j++;
        else j=Next[j];
    }
    if(j==nb) return i-nb+1;
    return -1;
}
int main()
{
    int t,x,ans;
    cin>>t;
    while(t--){
        cin>>na>>nb;
        for(int i=0;i<na;i++) cin>>x,a[i]=x;
        for(int i=0;i<nb;i++) cin>>x,b[i]=x;
        ans=kmp();
        cout<<ans<<endl;
    }
    return 0;
}
</span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值