算法练习(0)PAT-1042

算法仅为个人理解 不足之处欢迎指正~

1042. Shuffling Machine (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

  题目来源:https://www.patest.cn/contests/pat-a-practise/1042

 

题目使用谷歌翻译:

 

洗牌是用来随机化一副​​扑克牌的程序。由于标准洗牌技术被视为薄弱,并且为了避免员工通过进行不适当的洗牌与赌徒合作的“内​​部工作”,许多赌场采用自动洗牌机。你的任务是模拟洗牌机。

机器按照给定的随机顺序洗牌一副54张牌并重复给定次数。假定卡片组的初始状态按以下顺序排列:

S1,S2,...,S13,H1,H2,...,H13,C1,C2,...,C13,D1,D2,...,D13,J1,J2

其中“S”代表“Spade”,“H”代表“Heart”,“C”代表“Club”,“D”代表“Diamond”,代表“Joker”代表“J”。给定的顺序是[1,54]中不同整数的置换。如果第i个位置的数字是j,则意味着将卡从位置i移到位置j。例如,假设我们只有5张卡:S3,H5,C1,D13和J2。给定洗牌顺序{4,2,5,3,1},结果为:J2,H5,D13,S3,C1。如果我们要再次重复洗牌,结果将会是:C1,H5,S3,J2,D13。

输入规格:

每个输入文件都包含一个测试用例。对于每种情况,第一行包含一个正整数K(<= 20),即重复次数。然后下一行包含给定的顺序。一行中的所有数字用空格分隔。

输出规格:

对于每个测试用例,将洗牌结果打印在一行中。所有的牌被一个空格隔开,并且在该行的末尾不得有额外的空格。


算法分析

首先现有牌堆的初始序列是确定的(我们称为arr列),然后输入的是打乱次数(我们称为n)和打断方案(我们称为line列),打乱方案(line)的形式为一个数列,我们要将数列位置的单位转运到齐值为下标的位置。进行此操作n次完成打乱操作。要点,我们要进行多次打乱,所以line列从输入到结束都不可改变,我们在进行某次打乱操作的时候应该定义一个记录数组(tarr列),完成打乱后再将tarr列写入arr列,然后进入下一次打乱。

代码实现

 

#include "stdio.h"
int main()
{
    int arr[54],line[54],tarr[54];
    int n,i;
    for(i=0;i<54;i++)//牌堆初始化
    {
        arr[i]=i;
    }

    scanf("%d",&n); //洗牌次数
    for(i=0;i<54;i++)//输入洗牌顺序
    {
        scanf("%d",&line[i]);
    }
    while(n>0)
    {
        for(i=0;i<54;i++)
        {
            tarr[(line[i]-1)]=arr[i];
        }
        for(i=0;i<54;i++)
        {
            arr[i]=tarr[i];
        }
        n--;
    }

    for(i=0;i<54;i++)
    {
        if(i!=0) printf(" ");
        if(arr[i]==53) printf("J2");
        else
            if(arr[i]==52) printf("J1");
            else
            {
                switch(arr[i]/13)
                {
                    case 0:printf("S%d",(arr[i]%13+1));break;
                    case 1:printf("H%d",(arr[i]%13+1));break;
                    case 2:printf("C%d",(arr[i]%13+1));break;
                    case 3:printf("D%d",(arr[i]%13+1));break;
                }
            }
    }
    return 0;
}

此篇为自习笔记,有错误或者提问的地方,评论区留言,谢谢大家=w=

 

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值