USACO 1.4.1解题报告

Packing Rectangles
IOI 95

The six basic layouts of four rectangles

Four rectangles are given. Find the smallest enclosing (new) rectangle into which these four may be fitted without overlapping. By smallest rectangle, we mean the one with the smallest area.

All four rectangles should have their sides parallel to the corresponding sides of the enclosing rectangle. Figure 1 shows six ways to fit four rectangles together. These six are the only possible basic layouts, since any other layout can be obtained from a basic layout by rotation or reflection. Rectangles may be rotated 90 degrees during packing.

There may exist several different enclosing rectangles fulfilling the requirements, all with the same area. You must produce all such enclosing rectangles.

PROGRAM NAME: packrec

INPUT FORMAT

Four lines, each containing two positive space-separated integers that represent the lengths of a rectangle's two sides. Each side of a rectangle is at least 1 and at most 50.

SAMPLE INPUT (file packrec.in)

1 2
2 3
3 4
4 5

OUTPUT FORMAT

The output file contains one line more than the number of solutions. The first line contains a single integer: the minimum area of the enclosing rectangles. Each of the following lines contains one solution described by two numbers p and q with p<=q. These lines must be sorted in ascending order of p, and must all be different.

SAMPLE OUTPUT (file packrec.out)

40
4 10
5 8

由题意可知,四个矩形只有6种排列情况,其实,四和五可以合并为一种情况,那么只剩五种情况,前四种直接按数学方法计算即可求得面积,后一种要分三种情况,讨论是否重合,只有在不重合的前提下,才能计算其面积,四个矩形前排列只有24种情况,由深搜即可得到其全排列,然后每种情况计算其面积就可以,代码比较长,注意要细心。

代码如下:

/*
ID:jinyuxu2
LANG:C++
PROG:packrec
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int p,minarea;
int str[4][2];
struct node
{
 int area,row,col;
}rect[3000];
void Push(int x,int y)
{
 int s=x*y;
 if(x>y)
 {
  int t=x;
  x=y;
  y=t;
 }
 if(s<minarea)
 {
  rect[0].area=s;
  rect[0].row=x;
  rect[0].col=y;
  minarea=s;
  p=1;
 }
 else if(s==minarea)
 {
  rect[p].area=s;
  rect[p].row=x;
  rect[p].col=y;
  p++;
 }
 else
  return;
}
int cmp(const void *a,const void *b)
{
 return(((struct node *)a)->row-((struct node *)b)->row);
}
void Select(int t)
{
 int x,y;
 if(t==1)
 {
  x=0;
  y=0;
  for(int i=0;i<4;i++)
  {
   if(str[i][1]>y)
    y=str[i][1];
   x+=str[i][0];
  }
  Push(x,y);
 }
 if(t==2)
 {
  x=0;
  y=0;
  for(int i=0;i<3;i++)
  {
   if(str[i][1]>y)
    y=str[i][1];
   x+=str[i][0];
  }
  if(x<str[3][1])
   x=str[3][1];
  y+=str[3][0];
  Push(x,y);
 }
 if(t==3)
 {
  x=0;
  y=0;
  for(int i=0;i<2;i++)
  {
   if(str[i][1]>y)
    y=str[i][1];
   x+=str[i][0];
  }
  y+=str[2][0];
  if(x<str[2][1])
   x=str[2][1];
  x+=str[3][0];
  if(y<str[3][1])
   y=str[3][1];
  Push(x,y);
 }
 if(t==4)
 {
  x=0;
  y=0;
  for(int i=0;i<2;i++)
  {
   if(str[i][1]>y)
    y=str[i][1];
   x+=str[i][0];
  }
  if(str[2][0]>str[3][0])
   x+=str[2][0];
  else
   x+=str[3][0];
  if(y<str[2][1]+str[3][1])
   y=str[2][1]+str[3][1];
  Push(x,y);
 }
 if(t==5)
 {
  if(str[0][0]<=str[1][0])
  {
   if(str[2][1]<str[1][1]&&str[3][1]<=str[2][0])
   {
    x=str[1][0]+str[2][0];
    y=str[0][1]+str[1][1]>str[2][1]+str[3][0]?str[0][1]+str[1][1]:str[2][1]+str[3][0];

   }
   if(str[2][1]>=str[1][1]&&str[2][1]<str[0][1]+str[1][1]&&str[0][0]+str[3][1]<=str[1][0]+str[2][0])
   {
    x=str[1][0]+str[2][0];
    y=str[0][1]+str[1][1]>str[2][1]+str[3][0]?str[0][1]+str[1][1]:str[2][1]+str[3][0];
   }
   if(str[2][1]>=str[0][1]+str[1][1])
   {
    x=str[3][1]>str[1][0]+str[2][0]?str[3][1]:str[1][0]+str[2][0];
    y=str[2][1]+str[3][0];
   }
   Push(x,y);
  }
 }
}
void DFS(int t)
{
 int a,b,c,d;
 if(t>=4)
  return;
 if(t==3)
  for(int i=1;i<=5;i++)
   Select(i);
 DFS(t+1);
 a=str[t][0];
 b=str[t][1];
 for(int i=t+1;i<4;i++)
 {
  str[t][0]=str[i][0];
  str[t][1]=str[i][1];
  str[i][0]=a;
  str[i][1]=b;
  DFS(t+1);
  c=str[t][0];
  d=str[t][1];
  str[t][0]=str[i][0];
  str[t][1]=str[i][1];
  str[i][0]=c;
  str[i][1]=d;
 }
}
void choose(int t)
{
 int a;
 if(t==4)
 {
  DFS(0);
  return;
 }
 choose(t+1);
 a=str[t][0];
 str[t][0]=str[t][1];
 str[t][1]=a;
 choose(t+1);
 a=str[t][0];
 str[t][0]=str[t][1];
 str[t][1]=a;
}
int main()
{
 freopen("packrec.in","r",stdin);
 freopen("packrec.out","w",stdout);
 p=0;
 minarea=0x3fffffff;
 int x,y;
 for(int i=0;i<4;i++)
 {
  scanf("%d %d",&x,&y);
  str[i][0]=x<y?x:y;
  str[i][1]=x>y?x:y;
 }
 choose(0);
 qsort(rect,p,sizeof(rect[0]),cmp);
 printf("%d\n",rect[0].area);
 printf("%d %d\n",rect[0].row,rect[0].col);
 for(int i=1;i<p;i++)
  if(rect[i].row!=rect[i-1].row)
   printf("%d %d\n",rect[i].row,rect[i].col);
 return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
代码下载:完整代码,可直接运行 ;运行版本:2022a或2019b或2014a;若运行有问题,可私信博主; **仿真咨询 1 各类智能优化算法改进及应用** 生产调度、经济调度、装配线调度、充电优化、车间调度、发车优化、水库调度、三维装箱、物流选址、货位优化、公交排班优化、充电桩布局优化、车间布局优化、集装箱船配载优化、水泵组合优化、解医疗资源分配优化、设施布局优化、可视域基站和无人机选址优化 **2 机器学习和深度学习方面** 卷积神经网络(CNN)、LSTM、支持向量机(SVM)、最小二乘支持向量机(LSSVM)、极限学习机(ELM)、核极限学习机(KELM)、BP、RBF、宽度学习、DBN、RF、RBF、DELM、XGBOOST、TCN实现风电预测、光伏预测、电池寿命预测、辐射源识别、交通流预测、负荷预测、股价预测、PM2.5浓度预测、电池健康状态预测、水体光学参数反演、NLOS信号识别、地铁停车精准预测、变压器故障诊断 **3 图像处理方面** 图像识别、图像分割、图像检测、图像隐藏、图像配准、图像拼接、图像融合、图像增强、图像压缩感知 **4 路径规划方面** 旅行商问题(TSP)、车辆路径问题(VRP、MVRP、CVRP、VRPTW等)、无人机三维路径规划、无人机协同、无人机编队、机器人路径规划、栅格地图路径规划、多式联运运输问题、车辆协同无人机路径规划、天线线性阵列分布优化、车间布局优化 **5 无人机应用方面** 无人机路径规划、无人机控制、无人机编队、无人机协同、无人机任务分配 **6 无线传感器定位及布局方面** 传感器部署优化、通信协议优化、路由优化、目标定位优化、Dv-Hop定位优化、Leach协议优化、WSN覆盖优化、组播优化、RSSI定位优化 **7 信号处理方面** 信号识别、信号加密、信号去噪、信号增强、雷达信号处理、信号水印嵌入提取、肌电信号、脑电信号、信号配时优化 **8 电力系统方面** 微电网优化、无功优化、配电网重构、储能配置 **9 元胞自动机方面** 交通流 人群疏散 病毒扩散 晶体生长 **10 雷达方面** 卡尔曼滤波跟踪、航迹关联、航迹融合

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值