题目描述
输入
输出
示例输入
2 6 Add 18353364208 Add 18353365550 Add 18353365558 Add 18353365559 Del Out
示例输出
18353365558 18353364208
提示
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <string>
#include <queue>
#define qmaxsize 1000000
#define smaxsize 200000
using namespace std;
/*typedef struct node
{
string data;
struct node*next
}node;
typedef struct
{
node*front;
node*rear;
}sq;*/
int main()
{
int n,m,flag;
string x,a;//string类型相当于a为字符串
while(scanf("%d%d",&n,&m)!=EOF)
{ flag=1;//不标记会超时
stack<string>s;
queue<string>q;
while(m--)
{
cin>>a;
if(a=="Add")
{ cin>>x;
if(s.size()<n)
{
s.push(x);
}
else
{
q.push(x);
}
}
else if(a=="Del")
{ if(!s.empty())
{ s.pop();
if(!q.empty())//队列不空才能进入
{
s.push(q.front());
q.pop();}
}
else flag=0;
}
else if(a=="Out")
{
if(!q.empty())
{
q.pop();
}
else flag=0;
}
}
if(flag==0)
printf("Error\n");
else while(!s.empty())
{
cout<<s.top()<<endl;
s.pop();
}
}
return 0;
}