Can you find it? ——二分

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

/*
先保存(数组sum)数组a与数组b的每一个数字分别相加,再二分sum
*/


#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
#define ll long long int 
#define ull unsigned long long int 
#define e 2.718281828459
#define INF 0x7fffffff
#pragma warning(disable:4996)
#define pf printf
#define sf scanf
#define max(a,b) (a)>(b)?(a):(b);
#define pi  acos(-1.0);
#define  eps 1e-9;
const int MAX=505;
int sum[MAX*MAX];
int main(void) {
    int a[MAX], b[MAX], c[MAX];
    int L, N, M;
    int S,X;


    int time = 1;
    while (sf("%d %d %d", &L, &N, &M) != EOF) {
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        memset(sum, 0, sizeof(sum));

        for (int i = 0; i < L; i++)  sf("%d", &a[i]);
        for (int j = 0; j < N; j++)  sf("%d", &b[j]);
        for (int k = 0; k < M; k++)  sf("%d", &c[k]);

        int len=0;
        for (int i = 0; i < L; i++)
            for (int j = 0; j < N; j++)
                sum[len++] = a[i] + b[j];
        sort(c, c + M);
        sort(sum, sum + len);
        len=unique(sum, sum + len)-sum;//除去重复的数字,计算去重后的长度

        cin >> S;
        cout << "Case " << time++ << ":" << endl;

        while (S--) {
            cin >> X;
            bool judge = false;
            //if (X  > c[M - 1] + sum[len - 1] || X  < c[0] + sum[0])
            //              pf("NO\n"), judge = true;//超出范围的数字直接判断
            //  加了就WA为什么呢
            for (int i = 0; i < M&&!judge; i++) {
                int find = X - c[i];
                int left = 0, right = len - 1;
                int mid;

                while (right >= left && !judge) {

                    mid = (right + left) / 2;

                    if (sum[mid] > find)
                        right = mid - 1;
                    else if (sum[mid] < find)
                        left = mid + 1;
                    else
                        pf("YES\n"),judge=true;

                }

            }
            if (!judge)
                pf("NO\n");
        }


    }



    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值